DTTG 3.0.5 Won't Sync via Bonjour

Same here. Syncing using Bonjour works with neither the iPhone nor the iPad. The computer will sync with dropbox, legacy, and cloudkit. Usually those are only for backup reasons/cloudkit when I’m traveling. Syncing the iPad with eg. legacy works fine.
Background: I have six databases, and about 300,000 documents. Just deleting them on any device and syncing them back takes up to a month. This is not an option for me.

2 Likes

You have a huge amount of stuff being synced. If Legacy, Dropbox, and CloudKit all work, they why not just rely on them and forget about Bonjour? (Somewhere along the way I recall DEVONthink people here saying to use only one Cloud-type sync at a time, so I guess you should consider picking one).

Yes indeed it is huge. The normal sinking supposed to go through bonjour. The others I just used once in a while because the traffic is just enormous. So when not otherwise necessary, I prefer bonjour. Dropbox is just a backup solution (you never know when those blackmailers from bitcoin it will hit you)…

Remember: Syncing is not a backup. Just not. Use proper backups to protect yourself from those blackmailers!!! Backup discussed at length here in other posts and on the “net”.

… I have been using DTPO for over 10 years … it works great for me …
(backing up using sync works fine as long as you know what you are doing…)

So … your machine and/or DEVONthink database gets corrupted or attacked, say a week ago, and today you just heard about it. Meantime, your database (the corrupted one) was synched a few times. After you deal with the root cause of the problem (could even be something as simple as a partially corrupted hard disk or something), you go to the “synced” copies on other devices to restore … and, oops. It’s corrupted too. Oh well.

5 Likes

Exactly. That’s why the sync is not recommended as a backup, especially not as the only backup.

I’ve worked through all the steps in this thread, a reinstallation, tips from a support ticket, even attempting to sync to my other Mac via Bonjour–and just nothing…Bonjour had been rock solid and then that day it just…stopped…

Bonjour is still working between the Macs, it is just with the iPhone that it just keeps failing.

1 Like

Just to chime in that you’re not crazy. I have tried those steps too and it appears that the initial sync worked once (but it was excruciatingly slow) and after that, same behavior as before. Some databases never sync, one or two synced once but then never sync again and the log is flooded with connection timeouts. Sync between two macs works fine.

@BLUEFROG has been very attentive in support and I trust that they’ll sort it out eventually!

3 Likes

Glad to know I’m not alone!

And yes, @BLUEFROG has been fantastic. I cannot say enough about the level of support you (and the other DT folx) provide to your customers. It stands in stark contrast to your “competitors.”

5 Likes

Just to add that I am having he same problem with local syncing since 3.0.5. Prior to that I was having no issues at all. I haven’t tried deleting things but have restarted my mac, iPhone and iPad with no change. I am getting server timeouts on my iPad in the log window but not my iPhone. The behavior during sync is to see at the spinning circle for each database but on “completion” show an old date/time in the sync status window. Having said that, the Global Inbox has just successfully finished a sync on my iPad this morning. I can provide more details but just wanted to let you know that at least one more person is struggling with sync since 3.0.5.

1 Like

I‘m having the same issue since the latest DEVONthink to go update/end of March 2021. Uploads from my iphone to my Mac still work, but no updates, new files or file deletions are synched back to the iphone. Also: Bonjour seems to work via WiFi only now: attaching an USB cable and putting the phone into flight mode now shows all bonjour databases as offline.

I am seeing no issue with syncing Bonjour via cable.

Have you quit and relaunched both DEVONthink and DEVONthink To Go?

1 Like

Yes. I also restarted both, Mac and iPhone.

In DEVONthink To Go, select Help > Contact Us to start a support ticket so we can have a look at the logs. Thanks!

1 Like

I am having the same issue - no bonjour-sync anymore between my iPad and my Mac. Everything is exact as pfarrelle described it - only that no database is syncing again till now.

I have tried everything which is mentioned here in this thread, except deleting DT2g because I have a lot of new data there which should be synced back to my Mac!

I deleted the sync-store on the iPad, tried it new with Wifi and USB, restart everything, switched off all databases except for one, changed order of - no chance - spinning circle on iPad and no sync. The cloud-icon shows no triangle. Mac log shows lost connections to the iPad while showing „mobile@nameofmyipad.local“ as file/action. _devoncloudy._tcp ist all the time active (Discovery) with my Mac as the one and only entry - HostName of my Mac shown there is of the form devicename.internal-domain.local.

Let me know what I can do to help solving this problem. Sync is very essential for my daily work so I would be happy for any help.

Thanks and greetings

We are currently testing a modification that may address this issue. Thanks for your patience, assistance, and understanding

4 Likes

Hadn’t used my iOS devices since noticing this problem. I checked them out today and they synced - I was surprised until I realized that I’m now running 3.0.6.

So, 3.0.6 now allows syncing over my local network as before - Many Thanks!

2 Likes

Thank you very much for listening, working, solving! My 3.6.3 Mac-Server-Edition is syncing with my 3.06 Dttg on iPad pro via Bonjour again. Wonderful! My daily work-horses are talking again with each other. :slight_smile: Puh. Thank you very much!

1 Like

You’re very welcome and we’re glad to hear it.
:slight_smile: