DTTG 3: round tripping PDFs?

There are certainly some interesting new features and a better “look” to DTTG.

I read (here) that one can now “Open documents in-place with third-party apps”.

I was wondering if that meant we would now be able to open a pdf in a third party app from DTTG and use the third party app’s annotating abilities without having to “roundtrip” the document?

I am wondering if this is right and, if so, how to do it?

I tried with a pdf in DTTG 3, used the share button to open it in iannotate, made a couple of annotations and used the share button to send it back to DTTG, but this just sent the annotations into DTTG as either Rich Text, Formatted Note, Markdown or Plain Text.


See current discussion ongoing How to work in other apps and see changes in DTTG

We don’t use iAnnotate so I can’t speak to the specifics there, but you should not need to share the file back to DEVONthink To Go. That would obviously generate a copy or some other output, as you’ve seen.

After annotating, you should be able to just close or switch away from the document, and if the app is behaving properly, the changes should be reflected in the file in DEVONthink To Go.

I just tried that with GoodReader and it worked as described.

Good to know of another well-behaved app. Thanks!

I’d like to add that this also works with the PDF-annotation apps Highlights and PDFPen on iOS. I couldn’t make it work with PDF-Expert. Only thing is: you have to close the annotated file in the annotation app, before you return to DT. Then, within DT, you have to switch out of the document view and back in again, for the annotation to be visible (and thus saved within DT). This is still not as it ‘should be’, but very much workable and much quicker than digging around in the document provider. Both are iOS annotation apps I can endorse by the way, with Highlighs also offering the possibility to additionally save the annotations to DT as a separate file.
Have fun!


I could get it to work properly in Highlights too.

No luck with PDF Expert or PDF Viewer though.

Hi Bluefrog, thank you to the DT team for the great update. Other than pdfs, do you think we will be able to open documents like omnioutliner from DTTG, or is that outside the scope of what can be done currently?

You can add GoodReader to the list of PDF apps that do not play well with DTTG3 round tripping. Indeed, at first I was very excited and GoodReader seemed to work well – until a window appeared in GoodReader stating “Fatal Error - The File being edited was modified outside GoodReader …”

This raises the question of what apps do play well with this functionality?

We have already had a report that GoodReader worked fine.

We don’t have such a list as we don’t run all the applications available. Others running the apps must be willing to test and share their experiences.

Thanks for the kind words!

I have no data regarding OmniOutliner. If you’re running it, you could test it and report back

I actually thought it didn’t work, but it does. It is necessary to download the file even though it says unknown. Then the share sheet becomes available and no longer grayed out. So that’s great.

I also just noticed that we could sort on created added modified and visited. Please don’t tell me that’s been there all along! Any way is very helpful.

I am using DEVONthink To Go 3.0.1 and using GoodReader 5.8.1135. When I attempt to share a pdf form DTTG for annotation in GoodReader, the pdf opens successfully in GoodReader, but approximately 90% of the time after a few annotations I receive a “Fatal Error” and find that, when I return to DTTG the pdf shows the initial annotations, but not the annotation immediately prior to the error. An example.

Indeed the multiple date methods have been there since version 2. :wink:

Does the issue recur if you stay with one highlight color?

Yes. Tried this morning on a “clean” pdf (I created it myself demo a word document) and had the same problem using just a yellow highlight annotation. Indeed, in my trail-and-error (no pun intended) approach, the type of annotation (highlighting, freehanded annotations, adding a text box) doesn’t seem to matter. Nor does the number of annotations seems matter – sometimes the error occurs after 2 or 3 annotate-save cycles, sometimes after 5 or 6. I have also tried it with indexed files and non-indexed files.

1 Like

I’ve also had this exact problem with GoodReader.

If anybody has any other suggestions for PDF readers that do work with DTTG I’d appreciate it - I am looking for one with a built in text-to-speech (which GoodReader and PDF Expert both have).

1 Like