DTTG: Annotating PDF no round tripping

I used to be able to annotate a PDF stored in DTTG by opening it in iAnnotate rather than making a new copy in iAnnotate.

When I click on the “share” button, there is an open in iAnnotate option, however, changes made in the resulting iAnnotate document do not sync back. I am trying to avoid creating a new copy every time I annotate a pdf.

It looks like, from this post https://talk.macpowerusers.com/t/devonthink-edit-question-ios/4553, that it is possible with PDF Expert but only if one uses iCloud.

I don’t use iCloud for this but Dropbox. Is it possible?

ps DTTG v. 2.6.5 (16323).

pps I know there are annotation tools in DTTG (and have paid for them), but I need the power and flexibility of the standalone apps.

DEVONthink to Go supports iOS’s “file provider” service, which means that other apps – such as PDF Viewer — can open a document stored in your DEVONthink to Go database(s) via the iOS Files app, permitting you to edit the document in situ, so that when you save the annotations/edits the original in the database is what is updated. This syncs back to your desktop from DEVONthink to Go.

This has been a feature of DEVONthink to Go for a very long time, so check the forums and documentation for more detail on how to use it.

(Although DEVONthink supports file provider, not every app on iOS does – DEVONthink cannot do anything about non-compliant 3rd party apps.)

good point, I miss such a feature for Apple Works and MS Office documents, too.
Something like „edit in…“ or „open in…“ instead of „clip to…“ (what usually hapens if you choose „open in…“). The re-redirection via Files.app is pretty boring.

Have you tried to use the in App purchase for PDF annotation? works really nice - at least for me :slight_smile:

Thanks, Korm

Yes, I have followed the instructions in the post I linked to.

Doesn’t seem to work at all for iAnnotate.

Works well in PDF Expert and PDF Viewer except for the one database I regularly work in! The folders/icons flash briefly, then I get a message “Content Unavailable”. This particular database is by far my largest. So maybe it’s a size issue and I have only the free iCloud account.

Thanks also Airestocky. Yes, I have the inApp purchase. I need the power of the third party apps though.

I’m having what may be the same problem. Most of the time, when I try to open something in my DTTG database – which is not very big! Only 650 items, ~1GB – I just started using DevonThink a month ago! – in an external application, the contents start shuffling around for a few seconds, and then they disappear and I see instead “Content Unavailable: The folder contents could not be displayed because of an unknown error.” The same issue reported here, a year ago: https://blog.devontechnologies.com/2017/09/devonthink-to-go-supports-ios-11/#comment-674052.

Sometimes opening DTTG and resyncing the database fixes this. Sometimes not. Sometimes DTTG doesn’t even show up as a location in the File Provider UI, and then I need to restart my iPad entirely.

This is on an Ipad Pro 10.5, iOS 12.1, >10GB free space available. I’m synchronizing the DB with iCloud, but I have 150GB free on iCloud, so that’s not the problem. (It also happens on my iPad Mini 4.)

The entire reason I purchased DTpro and DTTG was so that I could have a single database, with good search capabilities, synchronized across all my devices, that would let me edit the files (especially PDFs) seamlessly using external apps. This bug is making that very difficult.

If the problem is that my database is “too big”, something really needs to change, because anyone using DT as I’d like to (as an academic or student, storing articles and books) will quickly get something just as big – and my iPad Pro was until a few weeks ago the most powerful you could get.

Anyone have advice or know why I’m not seeing more information about this elsewhere?

The issue is not with a database being too big. Files.app is still not bug-free and there seems to be a memory / timing issue wth it we can’t quite pin down yet. It’s also an uncommon error, so there’s less data to investigate with. We are aware and looking into what we can. Thanks for your patience and understanding.

It’s definitely not uncommon for me! It happens maybe 75% of the time when I try to open a DTTG PDF from an external app or in Files.

I saw on another thread that you were offering to send a user an extended-logging build of DTTG in order to pin down a bug. Would you like me to install that build, to give you more data on this issue? It may only affect a few people, but for those it does, it really messes with the whole value proposition of DevonThink.

As I say, bizarrely, it is just the one group within one database. Unfortunately, the one I use (or would like to use) the most.

If there is any further information I can send you, let me know; but I have to warn you I wouldn’t know where “the logs” are (if there are such things on an ipad).

Do you have any JPEG files in the group?

Yes. I went through the database in question; there were six jpegs.

I converted them to png or pdf files on my Mac.

Once the databases had “synced” so that the iOS files showed up as png or pdf rather than jpeg, Files app still won’t open that one group.

The group does open no problems in DTTG, just not Files.app.

By the way, it did take a long time for the iOS version to sync with the Mac version even over the same local wi-fi network. I couldn’t see any way to “force” the sync.

I am using the sync store method via Dropbox rather than iCloud. Set it up ages ago and haven’t changed over: ideally I would not pay for iCloud storage as well as Dropbox.

Just for the sake of accuracy of the record, if you are using Dropbox to sync your DEVONthink data, as I think you had stated above, then your iCloud account, it’s size, or any issues associated with it, aren’t involved at all in any part of the process.

I’m going to add my observations regarding failures of the files app (or maybe DTTG). I’m working with a new MacBook Pro 15 inch and an iPad Pro 11 inch (also 2018). My iPhone X is also part of the equation, but it is not vital in my workflow. I sync successfully with a sync store in Dropbox, no indexed files/folders used. (BTW Devon, thank you, thank you for a fantastic ecosystem!)

I recently defined a smallish Numbers spreadsheet to add to my “Dashboard” group in an investment DTPO database. On the Mac, DTPO provides the necessary link to Numbers. On the iPad Pro, I get all the files on demand. I’ve turned on the “file provider” service. My problem is basically the same as pnorthup’s. Whether I start in the files app or Numbers, I go to iCloud and go into the DEVONthink link. There I am able to traverse to the Dashboard group. The first time I tried to reach the spreadsheet file and get it in Numbers, everything worked. As I recall the subsequent repeats of this workflow continued to work. Then it didn’t.

When I go into Dashboard, the contents (about 2 subgroups and 3 MD files and the spreadsheet) briefly appear then disappear leaving behind a message “Content Unavailable” and a text link to try again. Trying again repeats the disappearing act. Going up to the parent group at times results in the same thing for the parent’s contents. If I start at the top of the database, I can then go down the hierarchy. At times, if I go to another database and return, I am able to look inside Dashboard, but from there on, same result. Even shutting down the iPad and starting up again usually doesn’t work. But every now and then, I can view inside Dashboard and invoke the spreadsheet in Numbers.


  1. if I click the Dashboard group icon and very quickly tap the spreadsheet file icon (in a fraction of a second) before it disappears - this assumes I previously noted the icon’s location by going through the process that leads to “Content unavailable” several times to spot the exact location - then I can open the file in Numbers.

(Yes, Jim’s suspicion of timing and possibly memory may well be the culprits.)

  1. Once the file has been opened in Numbers the first time, I can then open it easily by choosing Recents in Numbers and tapping the file’s icon. Presto the file is invoked from DTTG. When leaving the session in Numbers, updates are written to the DTTG file.

Solution 2 is the way to go. It relies on the third party app having a “recents” feature.