DTTG can't sync/crashes

I’m very disappointed about this software. It simply doesn’t work. I’m trying to use it on a new iPhone 4 with iOS 4.2.1. When I try to sync it to my laptop in the local wifi network it either

  • cannot find the the laptop
  • or finds it and crashes (application error) after that number input dialog

All other iPhone apps are syncing fine over wifi. I even tried it without firewalls etc. but got the same non-results.

How can I get it to work?

We would like to help solve your problem but it would help to have some further details about your network, etc. In the meantime, please try these steps:

Make sure that your Mac firewalls have an exception set for your DT desktop product (in System Preferences, go to the Security icon, select the Firewall tab, click ‘Advanced’, and add your DT desktop product to the list of “allowed” applications). If that fails, then try creating a “private network,” go to the Airport icon in the menu bar (or in System Preferences, Network) and choose “Create Network…”. This allows you to create a network just using the WiFi on your Mac. Create a network and see if you can sync your device over this ‘private’ network. If this works, it means that your WiFi router is either dropping a fair number of packets when communicating between your device and the Mac or the WiFi router is blocking our protocol. It should be noted that we use our own protocol for communicating between the desktop product and your iOS device. While more secure, it is also somewhat less robust than higher-level protocols like HTTP when it comes to dealing with dropped packets. And while known protocols like HTTP or FTP are “understood” by WiFi routers, if security features are set to ‘high’ on some routers, they may see our protocol as being suspicious and block it. In any event, please try the above steps and let us know if they have any effect. If the “Create network” approach works, then you might need to look at your WiFi router’s settings to see if there is something blocking our traffic. In any event, let us know what you find after trying one or both of these approaches."
In this particular case, it might be useful to see if distance from your WiFi router (on the part of the device) makes a difference. As noted above, our protocol is slightly more susceptible to vagaries of network traffic (even on a closed, home network). We are not suggesting you need to keep your device next to your router in order to sync, but from personal experience there are areas in a house where WiFi “works” but is still dropping a lot of packets, which will cause our network stack to time out.

Let us know if any of these steps work or fail for you. If none of these steps address the problem, please file a bug report with us and please provide as many details as you think are relevant to helping us address the problem(s) you have encountered.

As I mentioned, I switched all firewalls off while trying to connect with DTTG. I’m also sitting next to the WLAN (AVM FritzBox 7270) router. As far as I can see that one is only configured to filter traffic going out, not internally.

The private network approach, without the router, didn’t help, there was also no synchronization happening.

Everything else, for example Things, is synchronizing nicely, so I must guess it is the DTTG application that is the problem. Unfortunately DevonThink Pro doesn’t say very much about the connection, it just keeps saying that it lost the connection.

Please file a bug report - this will allow us to interact with you more directly. That said, it would appear that there is some issue that exists on your network that DTTG (or DT Pro) is blocking or interfering with our WiFi protocol. However, given that you are having problems even when creating a “local network” may indicate something going on with your Mac. In any event, we would like to help you resolve the problem but that is difficult in the Forum format. Thank you for your patience and we will try to determine the cause of your specific issue(s) with our product regarding sync issues.

I’m having the exact same case here! No firewall on my mac, no luck with creating a local network, nor with synching ‘normally’. This thread speaks of a bug report - has the bug been solved?

I reported problems with sync’ing to this forum on October 30th last year. We are now over 4 months and counting without a fix. DT should be ashamed.

I have the same problem. After a successful sync that took about 3 hours to complete (large medical library) I was able to open DTTG and inspect the files. However, after that first time, the application crashes every time on opening. Tried uninstall, resync, and restart, started fine the first time after reinstall, but crashed every time afterwards. Solution? I feel like a waste of time and money. Very disappointed.

  • What iOS version are you running?
  • Is DtTG attempting to re-open a previous file when it crashes?
  • If you’re syncing with iTunes, you can look for crash reports in the following location:

Then you can send those logs directly to us at support@devon-technologies.com so we can work on troubleshooting.