DTTG crashes after update

After updating to DTTG 1.2.2 it crashes all the time.
I have deleted it and reinstalled but it’s the same.

It seams to be connected to bigger files, in my case Pages and Keynotefiles around and over 5 meg.

Either it crashes while try to open them or after opening when going to another folder.

Please fix this asap, I had enough of DTTG problems.

Best jakkke

I checked some more and it seams that it’s not connected to size. Some keynote files around 32 meg open just fine. But DTTG crases very, very often in a rate I never

Am I the only one having tis prolem or have all you other guys given up on DTTG?

Best jakkke

Which version of iOS are you running? Did these crashes occur in any earlier versions of DTTG?

Also, could you see if there are any crashlogs on your Mac in ~/Library/Logs/CrashReporter/MobileDevice/? If so, could you send a few of the most recent ones to us? Hopefully they can help us track the problem down.

i’m using 5.0.1 and I have had no crashes before. Most of my earlier problem was connected to sync but that seems to work now.

I mail you the 6 latest in a separate mail to you.



I have the same problem with crashes each launch.

Crashlogs to at - the link:

docs.google.com/open?id=0B7Skca … ZiYzI2YzBm


Thanks. I’ve emailed you back, so we can continue our conversation that way.

Thanks. Is DTTG crashing every time you try to launch it? Is there a particular document that DTTG is trying to open? Have you tried re-installing DTTG?

Hello jhjelle,

Is DTTG crashing every time you try to launch it?


Is there a particular document that DTTG is trying to open?

Yes: tk.de/centaurus/servlet/cont … Alltag.pdf

Have you tried re-installing DTTG?


This appears to be a bug with the PDF viewer we’re using. There’s an update which appears to fix it which I’ll include in the next update.

So when is the next update coming because the app is useless as it is now?

I plan to submit a minor update this week to address the PDF issue and any other small issues I can track down in time.

No, the update 1.2.3 does not fix the crash. And yes I have deleted and reinstalled and resynced.

Please fix this asap. It’s really hopeless to have an app which is not working as it is supposed to do and crashes even though you said you fixed it.

Sorry to say I can’t find an alternative app to use, any ideas?

Best jakkke

DTTG v1.2.3 is working on both my iPhone 4 (5.0.1) and my iPad 1 (4.3) with the PDF you pointed me to earlier: tk.de/centaurus/servlet/cont … Alltag.pdf

What kind of device do you have? Is it still crashing or is it exhibiting a different behavior now?


I didn’t point at that PDF I think it was someone else.
The files that make DTTG to crash for me is Pages files, and they crash when DTTG is trying to read them.

They have some graphics in them and if I open them and make some of the grouped graphics to pictures it seams to work.

Best Jakkke

Ah, you’re right. Sorry for the misidentification.

We use the built-in capabilities of iOS to preview Pages files. This sounds like an issue with that part of the system.

What version of Pages are you using to create these files? Do you have an example that you’d be able to send us to see if I can reproduce the crash and learn anything else from it?