DTTG does not show up as a document provider

I was very exited to read the changelog of the 2.1 release. Especially about the document provider part. But I have tested several apps and DTTG does not show up on any in the open dialog of the apps.
I tried the location menu but there is no DTTG to enable. Any ideas ?

Which version of iOS do you use? Updating to 10.12.1 and rebooting the device fixed this issue over here.

Your companion apps needs to support document providers also-not all of them do.

I am on 10.1 at the moment and can not update until next week Sunday. Did try a restart of the phone and it did not help.

I tried to open DTTG in the following apps: Documents, Pages, Numbers and PDFViewer from PSPDFkit. In neither app i could enable DTTG as a document provider.

How do these two menus in Documents appear on your machine? Press iCloud > iCloud Drive > Locations > More … for the one on the left, or iCloud > iCloud Drive > Locations for the one on the right.

In Pages or Numbers it is Location > iCloud Drive, etc.
In PDF Viewer it is + > iCloud Drive, etc.

They appear like this:

I am using DEVONthink To Go 2.1.1 on iOS 10.2.1 on an iPhone 6 with the latest version of Documents. I have no trouble there, or on an iPad. On the same menus you posted in your screen shot, DEVONthink appears on my phone. So, if you are using the same release of DTTG and iOS, and do not see the document provider feature, then I suggest you delete DTTG, reboot, reinstall, and re-synchronize.

Does this require iOS 10 to work? I have an older iPad that can only accept iOS 9. I don’t see the DTTG option in Documents under locations but it works on my iPhone using iOS 10

Document provided came along as part of Extensibility in iOS 8, with app providers added to the picker in iOS 9.

When I go to locations in Documents for example (or really any app supporting this) I see the option for Documents, PDF Expert and the option to toggle on Dropbox and One drive but no option of DTTG. On my phone I had the option to toggle DTTG on which allows the editing to work. Any thoughts?

Each app either supports it - or it doesn’t.
Each app also implements it in the way it wants to… unfortunately.

Documents on my iPhone and Documents on my iPad (both iOS 10.2.1, both DTTG 2.1.1) both work exactly the same and make DTTG and its databases available in the document provider document picker exactly the same way. There’s no apples and oranges; just apples and apples.

I would conclude there is something different between your devices that we don’t know about.

We attribute it to internal weirdnesses of iOS. Unfortunately, unlike the Mac, we cannot simply “delete a preference file” or “restart the Finder” :frowning:

Finally I am back home and was able to backup my phone before upgrading it from 10.1.1 to 10.2.1 and now DTTG is there as document provider.

This strengthens our theory that e.g. updating the operating systems makes it rebuild some caches including the list of available document provides. We’re glad the problem is solved for you!


For the record (and another data point) I’m seeing this same issue. Document picker on iPhone with iOS 10, but not showing up on iPad with iOS 9. Did a reinstall of DTTG, restarts, hard restarts, etc, etc and DTTG still does not appear i the document picker or the picker’s “More” menu. Seems like iOS 9 is just a lot less reliable in this regard!

Just picked up an iPad Pro and got things all set up. No issues with DTTG showing up as a document provider in any application (that supports the document provider).

I think iOS 9 (which my old iPad was stuck with since it was so old) is just very flakey, my 2 iOS 10 devices have never had any issues with providers (DTTG or otherwise) showing up. Not a lot likely to be done on DEVONtech’s side of things.

Our feeling too and why we advocate moving up to iOS 10.

Oh yes, absolutely. Had to move up to new hardware to do so, but very glad I did! :smiley: