DTTG Encryption Key not available

I get the error message “Encryption key not available”. It is as an error in the log but also is appearing as a recurrent notification. Which annoyingly is coming every few seconds.(in the last 10s I have had 5!)

This happened on my iPhone, I reentered the password and it went away. However it has started happening today on my iPad ??

Is this a bug…

I had the same issue last night right before a work trip. The iPad worked fine, the phone failed a little after 8pm PST. I haven’t retried the iPad, but I had to disconnect and resync with dropbox to fix the issue.


@apb123: Is this a Dropbox Sync? If so, it’s something going on on their side. We can’t reproduce it at will and haven’t seen it for awhile. Re-entering the key (in both places) should suffice.

Re-entering the password didn’t work for me, and I tried entering every place I could find a prompt for it. I noticed under sync locations that not all of my databases where showing up, only the ones that I keep on my iPhone. The databases that are only on my Macs for archive purposes didn’t show up.


Please start a Support Ticket.

Yes is a dropbox sync.

I have reentered the password and has gone away.

Third time this is happening to me, first time to read this. Unfortunately, each time it happened, entering the key again in both place as explained here wasn’t enough to get rid of the issue. I actually had had to delete the database in my iPad to resync the whole thing.

I mean seriously it’s a pain. We’re all busy and I don’t have the time to open a new ticket again and again about the very same issue.

Couldn’t we get a tutorial fix about this?

The next version of DEVONthink To Go will store the encryption password (encrypted) separately from the iCloud-synchronized preferences. It seems that the iCloud preferences synchronization destroys settings from time to time. I had this with OmniFocus recently too.