DTTG Not Searching Content of Any Document

When I conduct a search using the search bar in the left pane of DTTG, only the titles of documents in my databases are searched, even after I’ve pressed ‘enter’. The results are the same regardless of whether I specify that the search should be of all databases, only a single database, or only a single group within a database. All the documents in my databases are searchable (OCR’d PDFs, markdown, rich text docs, etc.), and equivalent searches on the same databases on the Mac version of DEVONthink work fine.

When I view a document on the right pane of DTTG, I am able to search within that document, so the search bar in the right pane is working correctly. But my left-pane searches don’t return hits in the contents of documents. I have tried reindexing all the databases by executing the reindexing command accessible via the appendix in the help page, but the problem persists.

Any help/advice would be appreciated. Thanks.

UPDATE: I continue to test this, and I’ve discovered that I can search the content using the left search bar, but only if the search is of one word. If I search “capital” or “Content:capital”, that works. But if I search “capital gain” or Content:”capital gain”, that does not return any hits of document contents, even though there are definitely documents in my databases that meet the search criterion.

Try using a + sign instead of a whitespace between the words. That works for me.

That worked. I tried Content:capital+gain and it worked. Thanks very much.

I’m confused, though. The DTTG documentation suggests that searching “capital gain” should have worked as well.

In any event, thanks again.

it would help the DEVONThink ToGo team if you could give the page number of the DEVONthink ToGo Handbook Document or section name in Help where you read that.

If you click on the help button (the question mark) next to the search bar in the left pane, you’ll see the following (see the fourth bullet point):

The available Boolean operators are…

  • “query1 query2 … :”

Matches the queries query1 and query2 etc. in exactly this order and with no other tokens between them.

1 Like

It used to work as described in the manual, but this changed in one of the recent updates.

Oh, I must have missed that. Thanks again. I’m glad it’s working.

The next maintenance release will contain bug fixes for search.

1 Like

I am a Mac/IPad refugee due to corporate decisions to go with MS. After year three, OneNote became worthless, so I moved my text data to a Markdown app (iA Writer) which is cross platform. I came across Devon and I am slowly peeling the onion away. Great product. In regards to search, mine stopped doing deep searches on the iPad, but it was still operational on my Mac.
I found out I kept the app open for a week on my Mac for a project and upon closing the Mac app, the iPad started working.
Being a newbie, that factoid may be found in the manual, which is work in progress for me.

1 Like

Welcome @cdonyochum

There is plenty of onion to peel away but fortunately you can use what you need effectively without having to get to the middle of it :relaxed:

Interesting. I generally keep DEVONthink open on my Mac all the time, but the searching issue I described in my first post was still there. Also, as I explore searching with DTTG 3 more, I’m coming to realize that a lot of the Boolean search commands (NEAR, for example) don’t work, or don’t work as well in DTTG 3 as they do for DT for Mac, which works very well. I look forward to the search bug fixes for DTTG 3.