DTTG shortcut stopped working in recent update

• iOS version 17.0.2 (update: also 17.0.3) on an iPhone 14 with 200 GB free space (update: also a 2018 iPad Pro 12.9" with > 300 GB free)
• DEVONthink To Go version 3.7.6

I use a shortcut to create notes on my phone. This was working fine; until recently, I used it nearly daily without trouble. In a recent update (either to iOS 17, or the latest DTTG, or both – I can’t tell which) this shortcut stopped working. Now when I try to run it, I get an error about “Could not run Create Item” because of a “problem communicating with the app”:

Testing process I’ve followed:

  1. Power down and restart the phone
  2. Open DTTG and let it finish sync’ing (using Bonjour sync)
  3. Switch to the Shortcuts app, and tap the shortcut to run it

What could cause this? What can I do to fix it?

That’s impossible to say without the shortcut itself and more information.

No one else has experienced shortcuts failing after the most recent updates?

Attached is a zip file containing the shortcut.
Note In dt.shortcut.zip (15.8 KB)

I doubt it would work for anyone else, since it relies on my specific databases, but hopefully it can at least be inspected in the Shorcuts editor.

There was an issue with quoted search strings – or a lack of quotes but not what you’re reporting.

When you run the shortcut manually what step fails?

What device are you running it on? IpadOS or iOS? Your shortcut runs fine for me on ipadOS, but I’ve troubleshooted a couple of shortcuts recently where something had changed in iOS that made a query fail.

If you actually manually open the shortcut in the Shortcuts app and press play on your device, you can watch it run through the different steps, and it should show you where in the shortcut the instruction fails, which will tell you which bit is broken (though as I said, I just ran it on ipadOS and it worked for me).

It’s the “Create” action for DEVONthink. Here is a screenshot, using the “log” option in my shortcut:

Is there any way to get more detail about the error, either from Shortcuts itself or DEVONthink?

Thanks for testing it. It’s quite puzzling that it works for you and not for me.

I posted a screenshot above showing which step it’s failing. (I only show one case out of the several cases in the shortcut, but in my testing, none of them work.)

Sorry, just noticed you did say iPhone. That’s what I get for replying whilst waiting for my Nintendo to update :rofl:

Are you writing to an indexed group by any chance?

1 Like

No – but that was a good question!

I’ve had a couple of issues with indexed groups so it was worth asking.

I think the issue is probably with the group though. Can you click on the group and re-search and choose the folder where you want the item to go, and then try again? It’s this option here in your shortcut:

When you search for the group where you want to save, Shortcuts should be showing you what options are available and you can click the one you want.

If this is a group within a database, the name should look like *database name* : *group name*

Yes – I’m quite familiar with this :-).

I’ve already “reconnected” (for lack of a better way to put it) all the destination groups.

You’re right to notice that the one shown in the screenshot above didn’t seem to be in the proper database: name format. But it turns out it doesn’t make a difference: I re-selected the desired group, it now does show in the proper form, and yet, the shortcut case still fails. Updated screenshot, showing the same failure:

Sorry, I’ve run out of ideas then, it’s working for me, I just tried it on my iPhone and it’s fine. Back to @BLUEFROG!

I really like your script though, do you mind if I tinker with it? It’s a great use of Shortcuts!

1 Like

Not at all – please feel free to use as you wish!

(Obligatory disclaimers: it comes with no guarantees of safety, fitness for purpose, or support, and my employer is not responsible for any part of it or my actions in this matter.)

Sorry, are you very sure the group name is correct? I know you said you’d checked but it’s easy to miss something. (My Nintendo is still updating so I’m still looking at your Shortcut :grimacing:)

In the Log action, the group is written like this: Diary


In all your other actions, it’s in the format I expected with the database name followed by the group name, like this: personal : Diary (or wherever, it changes depending on the action)

This latter format is correct, it’s the Log action that appears to have the incorrect location.

No. And it’s part of why Shortcut stinks. It’s near impossible to debug in any reasonable manner.

What are the internals of the Create Item action?

Yes, I updated my reply to you above to mention that the Log case was initially incorrect in my screenshots, but even after updating the group, it still fails in the same way. (Thank you for spotting that, and persisting in bringing it up. After slapping my forehead and fixing it in response to your reply, thinking for sure that was it, I was disappointed to find the shortcut still fails, even after quitting and restarting DTTG and then even my phone for good measure. This is a very perplexing problem.)

Additional info added later: I’ve also tested using the global Inbox instead of a database group, but it didn’t help; the problem still manifests in the same way.

I didn’t make it. Isn’t it provided by DEVONthink To Go?

If I do “Info” on it, here is what the Shorcuts app shows for it:

I just clicked on your profile as I was intrigued by your comment. I don’t know why I’m troubleshooting your Shortcut - you’re far more qualified than me and if you can’t make it work there’s no hope for me! :joy: I just think Shortcuts are fun and like testing them and making useless things with them, I have no idea how they work (to be fair it doesn’t seem like Apple do either…).

1 Like

This is absolutely not true. Please don’t say that. First, old farts like me are notoriously blind to their own limitations and prone to making mistakes due to their overinflated sense of expertise. Second, it is always useful to have another smart person looking over one’s work. I very much appreciated the time and effort you (a total stranger to me) put into this, and I paid attention to every suggestion. It made me re-check what I did – and you did spot at least one mistake in my original shortcut.

We didn’t get it to work for me, but we narrowed the possibilities.

Thank you!

1 Like