DTTG some rtfs empty

Dear all,

has anyone experienced the following problem:

I have some rtfs in the Mobile Sync group. When I open them on iPhone or iPad, some of them work fine, but some of them are shown as empty although they are not. The empty ones are the same on iPhone and iPad.

Moreover, for the empty ones, the “pencil” symbol for editing does not appear.
I tried to sync several times, it’s always the same: I see the content on the Mac but not on the iOS devices.


Which version of iOS and DEVONthink To Go do you use? Do the documents contain attachments (RTFD) or not (RTF)? Maybe the documents aren’t compatible to the used iOS version.


I’m using the latest version of iOS (8.3) and DTTG (1.5.6) on iPhone 5 (A 1457) and iPad mini Retina (A 1489). The files are shown as RTF on the Mac (I also used “Convert to RTF” to make sure, deleted the original and resynced). The problem remains. The file information on DTTG says “Formatierter Text”. The files only contain a few lines of plain text, nothing fancy.
If, however, I convert the files to plain text on the Mac, then the content is shown correctly on DTTG.


tom, could you please send me such an RTF so that we can test it here? My email address is eboehnisch (at) devontechnologies.com. Thank you!


I just bought DTTG and most of my synced RTF files, but not all, show titles but no body of text

I just bought DTTG and am having a similar issue. Most of the RTF files synced onto my iphone have titles but not body of text.

I’m having exactly the same problem. All of my rtfs display correctly on IMac desktop running Yosemite 10.10.3, but a good many show up empty on IPhone 6 and IPad 2, both running IOS 8.3. When I click on the “I” icon, the “empty” file is properly identified as RTF and a size is given. Like Tom, I’ve also tried re-syncing the databases to no avail. The only difference from Tom’s experience is that on the IPad 2 a rtf file’s contents will flash instantaneously on the screen before the file displays as if empty. I’ve compared the properties of rtf files that display properly in IOS with those that don’t, but can’t spot any differences. I recently updated to Yosemite from Mavericks, which had no problems with rtfs.

Any help or workarounds are welcome.



similar to dormanw, i once saw the content of one of the RTFs showing for an instant before vanishing. I think this happenend when i woke the iPhone from sleep.


Investigating this problem further, I’ve discovered that I can email “empty” rtf files to myself and they mostly open as attachments (one out of five did not). The inability to access the majority of my rtf files using DTTG is proving quite frustrating, the workaround of emailing them to myself notwithstanding.


This has started happening to me too. Yosemite & IOS are up to date as are DTTG & DTPO.

This is the reply I got today from DTTG Support:

It seems that a recent update to iOS broke the Omnigroup RTF editor that we’re using in DEVONthink To Go v1. We are already investigating this issue and will post an update to the App Store as soon as we have a fix. Please note that Apple’s review queue is currently around one week long so it may take up to two weeks before the next update will become available publicly.

Your DEVONtechnologies Team

So…patience is the byword.


Thanks for letting us know, Bill.

Since I have the exact same problem I just want to add the following:

Whenever I try to display one of those troublesome (very simple) rtf documents on the iPhone, the mod date of the file changes, and if you sync again to the Mac, the file on the Mac will also get a new mod date, in addition to a new creation date! That is destructive, and it’s done “behind my back”!
Extremely annoying!

I rarely use DTTG simply because of sync issues — a few years ago there were so many severe issues where I even lost information, which made me stop using it completely (I simply did not dare to use it).

DTTG 2 was promised to come with a completely new and more reliable sync, and it was expected to be released in 2013 (the current DevonThink pro Help still says that “Note: DEVONthink To Go 2, planned for release in 2013”), so I waited. Nothing happens though, and now I wanted to see if sync worked better than earlier. The first thing I stumble upon is this issue with some seemingly empty rft whose mod and creation dates get changed behind my back. So in conclusion: I think I still will not dare to use this DTTG, since it seems detrimental to information.

In addition, I haven’t found any rtf at all whose content I can edit on the iPhone without having to make a duplicate of the document (it says it is because of “formatting”). Thus, they are basically all read-only, which makes it even more strange that DTTG changes the mod and creation dates just because I try to display its content!?

I still run Mavericks, but the iPhone is new: iPhone 6 and latest iOS.

Updated DTTG 1.5.7 out that hopefully fixes this problem. Just downloading it.

Today’s 8.3 download fixed most but not all of my problems with empty rtfs. Any file with a RTFD suffix still displays as empty. I have no idea why the great majority of my files have a rtf suffix but a few have a rtfd suffix, and I have no idea how to change the file type. I tried cutting and pasting the content of the rtfd file into a new rtf type, but the type of file remained the same. As I say, the great majority of my text files are either plain or rich text, but a significant number are of the rtfd type and still won’t display. As with the earlier problem with rtf files, I can email an rtfd file to myself and read the attachment. If anyone knows how to change a file type from rtfd to rtf, I’d be eager to hear it. (Or if Devonthink can remedy this problem as well.)

I think I just discovered what may explain my latest problem after the 8.3 download. Evidently, an rtfd file is a Zip file. When I emailed the rtfd file to myself, it had to unZip before I could read it. After unzipping it, I tried copying the contents into a new rtf file, but it still saves only as an rtfd file. In other words, I can read the original rtfd file on my desktop with no problem, or I can email an rtfd file to myself from my DTTG app on IPhone, unzip and read it, but an rtfd file still will not read in DTTG as things stand after the 8.3 download.


RTFD documents are RTF documents containing images. You cannot just change the the RTFD file type to RTF unless you first remove the images from the document. RTFD documents are bundles (folder packages) containing the RTF file as well as all the images contained in the document.

RTFD documents have always been a challenge on iOS, and I’ve found it easier to convert RTFD documents to Formatted Note HTML documents or PDF documents.

Thanks, Greg, for setting me straight on this. I’ll follow your suggestions.


Well, as it turns out, my problem with RTFD files not displaying is indeed a new bug. I should have realized this at the start, given that my RTFD files had always displayed properly before the most recent round of IOS and DTTG updates. I shared my May 13 post with Support and here’s the response I received today from Devonthink:

Yes, it seems in the attempt to work around the issue in iOS 8.3 we introduced another bug affecting RTFD on iOS 8.3 and later. We have already fixed this, too, and sent an update to Apple which is now waiting for release to the App Store.

Your DEVONtechnologies Team,
Eric Böhnisch-Volkmann, President

Incidentally, I’m quite pleased with the rapid response of Devonthink support to my recent problems.


Just a quick note that Apple has approved the update to version 1.5.8 which fixes the RTFD problem we accidentally introduced when fixing the RTF problem on iOS 8.3. Please apologize the inconveniences.