DTTG stopped opening files from search

Recently (I don’t know since which update), DTTG doesn’t open files found through search. You tap on them and nothing happens. Navigating to the folder where there are located manually and opening them works fine. No sync errors are reported. Quitting the app and relaunching doesn’t help.

I’m using DTTG 3.6.5 (17316) on iOS 15.7.5.

Any ideas?


1 Like

With the same version of DEVONthink ToGo and iOS as you, I don’t see that problem with PDFs and Markdown files (the few that I tried).

  • What kind of files?
  • Indexed or Imported files?
  • When “navigating”, doing that navigation in DEVONthink ToGo, iOS Files app, or other?
  • Rebooting the iOS device make a difference?
  • What does the screen of “found files” look like? Perhaps ppst a screen shot? (I know I’m reaching here but you did ask for ideas!)
  • Files: probably all types (I’ve tried .pdf, .md and .txt).
  • All files are imported, not indexed.
  • “Navigating” refers to DTTG, selecting a database and digging into groups.
  • No (tried twice).
  • Please look at this screenshot. Tapping on any one of the two results has no effect other that highlighting it. I get the same result with other files. And, again, if I navigate to them I can open them by tapping, no problem there.

This is new behavior (although I can’t tell if it’s from a few weeks back or a month or two). It wasn’t happening during years of use.


1 Like

I had the same problem with .odt [OpenOffice text] files. I could locate them but couldn’t download them. What I did was use “extension==odt” (replace with the extension of your file) in the “search” field, hit enter, and magically, the problem was fixed.

Thanks. Not really fixed though. I can confirm that entering nothing but extension==pdf allows opening the file (which confirms that the problem is really a bug), although I could only test this by running it in a subgroup because I have too many PDFs to search the entire database.

However, this doesn’t solve the problem since, to quote my test above, entering faune and tapping on one of the files I’ve just opened using your suggestion has, again, no effect.

Also, if I do a search for faune extension==pdf or faune AND extension:pdf or any other similar combination, the problem remains.

More annoyingly, if I tap-hold the file and then select “Info”, the location of the file isn’t shown. I have to remember where it was saved in order to open it.

The file is there and can be opened, but only if you don’t search for it. Clearly a bug imho.

1 Like

I ran into this yesterday. Thankfully it related to a topic I can easily share here with this screen recording…
I think you can tell that when I tap on a doc it doesn’t open them but it does when I select a group.

This will be addressed in the next maintenance release. Thanks for your patience and understanding.

1 Like

Thank you for your quick feedback. Cheers.

1 Like

I am long pressing, then selecting reveal which allows a work around until fixed.

1 Like

I have the same issue on the Iphone version. On the Ipad everything works good.

As I mentioned above, this will be fixed in the next release.

1 Like

Thank you! I saw your message.
I’ve reported just to let you know about nuances of this bug.

No worries. The internal builds I’m testing are looking good, so stay tuned :slight_smile:


Is there a date for the next maintenance update? DTTG is almost unusable since it no longer opens documents from search.

A workaround I discovered yesterday was to press and hold on a search result and choose reveal from the contextual menu. This will at least open the file you’re looking at in search results.
Not the solution but a workaround until this is fixed.

Sorry but we don’t comment on release dates. And the interim process is to reveal the item, as @SlickSlack just mentioned.

On my end Reveal doesn’t open the file but rather the group it’s in. If the group contains a lot of items it’s a pain to rummage through. In the last weeks I’m rather using “Add to favorites” (a feature I don’t use very much) and just open it there.

Fixed in today’s release. Very nice squirrel, too.


Thanks for confiming :smiley: