DTTG3 IAP - "SKErrorDomain 0"

Hey team,
Congratulations on the release of DTTG3!

I have a bit of an issue when trying to “purchase” the Free Upgrade Intro.
When clicking the option, I am presented with the classic IAP screen where I need to confirm the purchase of “Version 3 (Free Upgrade Intro)”:

After confirming, “payment” is confirmed and then there’s an error roughly translated as “Operation couldn’t be achieved. (SKErrorDomain error 0.)”:

And that’s it, I can’t do anything else. I tried purchasing multiple times, it always fails with the same error. Also tried to uninstall DTTG3, reboot and reinstall: same outcome.
Also, not sure if this is expected, but the last 3 purchase options are greyed out?


  • iOS 14.4
  • Buying on the French App Store
  • DTTG 2.7.9 installed and sync’d
  • DTTG3 freshly installed
  • If that matters: I don’t have any parental control enabled, and I have a 2nd iCloud account enabled on my iPhone which is a developper account. Note that’s not the main one, and definitely not the account I’m trying to purchase with.

I can’t say if there’s the same error with the paid upgrade, as I didn’t try to purchase it.
I’ll eventually upgrade, but figured I would try it with thee free option first.

Let me know if you need additional details.

This is an issue with the App Store itself. Maybe restarting your device could help, switching networks, or simply waiting and trying again.

Ok. I rebooted, switched networks (2 different wifis + 4G), switched DNS servers, but still have the same issue. Note that I already had the same issue yesterday night (about 14h ago).
I’ll wait a bit and hope it gets fixed.

Tried today with update 3.0.1, on a different wifi network. Still no luck, same “SKErrorDomain” error message.

Unfortunately, I am also still getting the same error…

What iOS App Store are you connecting to?

I am on iOS 14.5 with Devonthink update 3.0.1 on my iPhone.

This error message is coming directly from the App Store so there’s not much we can do, actually. Have you tried to restart your device? Sign out of the App Store and sign in again?

But what App Store??
@julienma said he’s having an issue with the French Store.

I signed out and in, restarted the phone, changed wifi cellular and vpn. I am using UK app store. It’s still same.

Do you mean you disconnected the VPN? If not, try that.

I tried every possible combination of VPN, wifi and cellular data.

Ok, I solved the problem by deleting both versions V2 and V3 and installing them again. Then, I could get free upgrade without any further issues.

Note: Be careful deleting both applications you may lose your data if they are not in sync.

Interesting. Thanks for the follow-up.

Tried this as well, uninstalling and reinstalling both versions. Still the same error for me.
Did you setup your sync locations on v2 before installing v3? (I did not)

Before deleting both apps, I synced everything on V2. Then uninstalled V2 and V3 and installed them again. Open V2 just for a second (no sync or anything) closed it and opened V3. It went through without problem for me. I think that was a bit random…

Ok, thanks.
I uninstalled both apps, reboot, installed both again. Launched v2 for a second (no sync or anything), then launched v3 aaand… same error :frowning:

Can you access the iOS App Store sucessfully outside DEVONthink To Go?

I didn’t purchase an IAP recently, but yes, I can access the App Store and install apps.

Is anything reported as down here…