Duplicated groups when syncing

Ladies, Gentlemen,

As you may know we are fully concentrating on DEVONthink To Go 2 in our iOS development efforts. Still, I have just fixed a few bugs in version 1.2.x, e.g. the crash when showing the info screen for large groups or databases, and the bug that items could be renamed but that change was not reflected on the Mac. I have also added support for the iPhone 5 screen size.

One large issue seems to be that the sync sometimes creates empty groups on the Mac side. So war I am unable to reproduce this issue with my setup. Is anybody here you can reliably reproduce the issue and give me step-by-step instructions? That would be very helpful!


I don’t know if I can reproduce it, but yesterday night the sync created empty duplicates (more than half of all folders were affected).

I’m not sure how to tell you to reproduce it – it simply happens every time I sync. I have the app on my iphone and ipad as well as on my macbook pro. I had seen the problem almost from the get go. At some point I reset my synchronization settings, and I suspect that the problem started after that, but cannot say without any doubt.

Just a few minutes ago I did a synch from the iPad. Now, on my mac, I have duplicate groups. They are always empty. See the attached image.

Also, several groups have been renamed – maybe another clue – to an older name. probably the name of the group at the time of the previous sync. For instance, in the image, the group JOURNAL was recently renamed to LOGS. After the sync it is back to JOURNAL.

As you can see from the screenshot, no files are duplicated, just the empty groups. This means I have to go and clean house every time i sync. So, for now, I’ll stop using it.

If I can help, let me know. Hope we can expect a fix for this soon.
Screen Shot 2013-05-07 at 4.55.37 PM.png

Don’t know if this is related to the current sync problem with duplication but I just had two specific syncing problems, one I cured and the other I can’t seem to.

The first was a 200MB PDF that I moved from Global Inbox. It crashed the sync, and I eventually fixed this by duplicating it in my Mac database, deleting the original, then re-syncing.

The second is that I have a folder that I attempted to un-sync by deleting it in the Mobile folder as normal. It still shows as a replicant in my Mac database, yet it doesn’t appear in my Mobile folder, and still appears on my iPad database. When I try to sync, I’m told that there’s nothing to sync (which, going by the Mobile folder is correct). I’ve tried replicating again to Mobile, re-syncing, then deleting again, but to no avail. Not a fatal problem – I guess the folder will hog iPad space until a fix allows me to clear it. Thought I’d report it though in case it’s related in some way.

Just fixed the folder that wasn’t showing in Mobile Sync. The problem had two aspects.

  1. I managed to remove the folder from my iPad (the aim all along) by putting it into the Trash (i.e. on the Mac - note that I didn’t delete it once in the Trash). Then I synced my iPad and the folder disappeared from the iPad database.

  2. when I returned the folder from Trash to its original place in the Mac database, it still showed up there as a replicant. It was no longer on the iPad nor Mobile Sync at this point, so I did a See Also on a file and found that there was a replicant elsewhere in the Mac database (though why, I don’t know). This wouldn’t seem to explain 1) above, so I tell you about 1) and 2) in case the procedures are helpful in ironing out the syncing. Anyway, I deleted the inexplicable replicant and now everything matches across my versions.

Tip #1 also applies to documents as well as groups. From my experience, deleting documents from the Sync group and then emptying the DEVONthink trash before a sync will always result in the documents syncing back to the Mac from DEVONthink to Go. to get this to work I must delete the documents, sync DEVONthink to all iOS devices, then I can safely empty the DEVONthink trash.

How can we help you to identify the issue? What do you exactly need to get to the root of the issue?

I synced to my ipad for the first time with no problem.

Tonight I tried syncing to my iphone and after about 600 or so files devonthink on mac froze while trying to send over a large pdf (and ate about 10gigs of hard drive space while doing so). I tried syncing again and when I realized that the sync was sending iphone files over to my mac I cancelled out of that and deleted the iphone database and resynced.

After that I noticed not only about 20-30 duplicate blank folders on my mac, but also one of my main folders on mac previously labelled “personal” had been renamed “%placeholder%”.

I really can’t believe that sync is considered out of beta…if anyone is reading this and considering using the sync function, don’t! This shouldn’t have been released yet.

You are talking about two different technologies.

Could you explain what you mean by that? Thanks.

Seemed to me like Jim (BLUEFROG) might have thought you were confusing the newer technology currently only used for synching between DEVONthink desktop apps with the older sync technology still used for synching between Dt desktop and iOS apps. Yet both are considered non-beta, adding to the/my confusion. Now I’ll just shut up and let Jim speak for himself. :slight_smile:

sjk is correct. From the comment you made it appears you are under the impression that our recently released Sync technology is what syncs DEVONthink To Go with the Desktop. This is not the case. DTTG has its own sync process. However in DTTG 2 they will be the same.

I am having the exact same issue.

I just …

  1. Setup DT To Go completely anew on my iPad (iOS 6.1.3).
  2. Synced the iPad with DTPO once. Worked fine.
  3. Added one text note on the iPad.
  4. Tried syncing the iPad with DTPO again.

Now: iPad is “sending” (so the status screen on the iPad reads) a lot files that exist on both devices towards the Mac.
I canceled the sync shortly after the start and now there are tons of empty duplicate groups (i.e. groups with duplicate names, but the groups themselves are empty).

I am particularly surprised since this is happening on a pretty much completely fresh set up of DT To Go on my iPad.

The status message is misleading. Your iPad was only ‘sending’ status information of the files, not the files themselves, as long as they were not modified or created on the iPad - at least that is what happens typically, when you see that message. So, next time you can just let the sync happen.
Although this issue with duplicated, but empty groups is reported to happen also, when the sync is not interrupted, I would not be surprised if the reason here was the interruption of the sync: I am syncing some 30.000 files almost daily, but had this issue only once and this was, after I had killed the sync while it was running (or maybe was stalled in that moment).

By the way, I - here for me - have only seen problems with the sync, when large files are to be send. Then the sync typically hangs here. Maybe this is due to my network, but anyway, I’m only synking files <30mb (circa). And I don’t create or edit files in DEVONthink To Go, which is more due to my workflow, which should be different, when DEVONthink To Go v2 with a hopefully bulletproof sync will be available. Though the latter shouldn’t be a problem or causing the issue this thread is about, these two conditions are special in my situation and my syncs are fine everytime.

The next release of DEVONthink/note will fix this (and should be available soon).

I have DTTG and because of a computer glitch I had to uninstall it from my iPad, I have now re-installed it but not yet synchronised it. Just checking that when the new version is released it will be a free upgrade? I do not want to sync if the new version is immanent. Thanks.

Eric has already stated that DEVONthink to Go 2.0 will be a free upgrade, but I believe the new release to fix this that Christian is talking about is the next maintenance release of DEVONthink/DEVONnote.

Thanks Greg, I understand now.