EasyFind 5.0.2 not fully searching on macOS Monterey

Good afternoon!

While in the process of updating some systems, I have hit a roadblock using EasyFind. I currently use EasyFind 5.0.2 on a macOS 10.15.7 (Catalina) system to easily search a network volume that contains thousands of audio files.

When installing and trying to use EasyFind on a macOS 12.4 (Monterey) system, my inquiries only seem to search the root level of the shared volume (in this case, 6 folders and 1 file) and won’t go any deeper.

I’ve duplicated every setting I can think of, but nothing has worked so far. I’ve tried this on other systems on our network and get the same results. Success seems dependent on the OS version the system is running.

Any help or insight would be great! EasyFind really makes digging around on this volume much more manageable.

Does EasyFind have full disk access? A screenshot of the window on both machines would be useful for comparison.

Also, how is the drive mounted on both machines, i.e., via afp:// or smb:// ?

Yes, full access on both machines. Network Volumes and Desktop Folder. The drive is mounted via software that our RAID server uses. Mounted identically on both machines. It can also be mounted to appear as an external volume instead of a network volume, but that doesn’t change the result.

Here’s the successful search on Catalina:

And here’s the Monterey installation and failed search:

  • What RAID software?
  • Have you ensured it’s compatible with Monterey?

We use a RAID server from a company called Facillis. Yes, the software is compatible with Monterey. I would not be able to mount and use the network volumes if it weren’t.

1 Like

Any further insight here? It seems to be a Monterey thing with network volumes.

It’s definitely not a common issue, e.g. it works fine over here but it’s different RAID and simply mounted via SMB.

I don’t know if a solution to this was ever found, but I am experiencing the same issue on our systems here. Monterey 12.6.1 on both Apple Silicon and Intel and EasyFind 5.0.2 connected to Facilis shares.

Facilis client uses its own emulated filesystem on Mac and is not a “true” smb volume. They are emulating the Avid Unity/ISIS/Nexis shared storage platform format “avidfs” and the Facilis client controls mounting and unmounting of the volumes. These shares are mounted over ethernet or fiber channel at our facility and previously there was no issue with searching on pre Monterey machines using the (current for us) 8.1.2 version of Facilis software.

Full disk permissions are given to EasyFind but like the original poster, we don’t get any search results. Let me know if there is any additional information I could provide that may help with troubleshooting as EastFind is one of our favorite overall utilities and would love to be able to continue using it.

Addendum: I also wanted to add that this is not just isolated to EasyFind. I am unable to search the volumes with other 3rd party tools like Find Any File as well so I am guessing it has something to do with either how Mac OS or how Facilis is presenting the filesystem to the search clients.