Easyfind on macOS

When I try to access my home folder in finder on MacOS it opens it in Easyfind instead. I can’t find anyway of preventing this. Any ideas?

You are reporting abnormal behavior, not a function of EasyFind.

  • How are you trying to access the Home folder?
  • Are you running shortcut utilites, launchers, or have defined your own hotkeys ?

Thanks for responding so promptly.

None of the above. I just try to click on it in a Finder list of folders! The folder names are listed in the sidebar (see the example in the attached png) of a folder view for another folder.

Screen Shot 2020-01-28 at 10.57.27 AM|262x347

No problem.

Control-click the item in the Finder’s sidebar and choose Get Info. What’s it pointing at?

It shows "open with’ pointing to EasyFind. That’s flooded by a list of other possibilities starting with Finder (default), but when I move to that it opens in EasyFind anyway (reproducibly).

I also used “Show Info” and changed the “Open With” there to Finder. When I clicked on the folder it just blinked and froze me in Finder somehow. I couldn’t switch to any other application. I forced a relaunch of Finder and tried clicking on the home folder again and got the same result. Blah.

I would remove it, reboot the machine, and try adding it again in the Finder prefs.

As an alternative: Shift-Command-H opens the Home directory.

Thanks for all this. I tried those and some other variants. As it stands, I can get to the home folder and use various commands to move files etc. However, when I’m done I can’t bring any other apps into focus, because the finder window pops up in front again immediately. Normal operations resume after I force a restart of finder.

There must be some .plist or something else that’s corrupted, but I have no idea what or where it could be. The problem has survived a couple of system upgrades (maybe since 10.13), so it’s a problem that moves along with the file system. Under the new SIPS, I have no idea what can be done. I ran disk repair on Mac HD but I’m reluctant to do it on Mac HD - Data which may take a long time and I have little hope for it to be helpful anyway.

It’s a bummer.

You’re welcome and it’s a weird problem indeed. I’ve never seen is in all my years working on Macs either. :thinking: