EasyFind wants Automation Privileges but doesn't appear in that prefpane

Re-installing EasyFind I tried to use it to search my ~/Library folder and up popped the dialog asking me to add it to the System Preferences > Security & Privacy > Privacy > Automation area - but the app does not appear there, so this is impossible.

I tried dragging it into the pane, but that didn’t work…

You can’t manually add to the Automation preferences.
Have you given it Full Disk Access?

Yes, I had given it Full Disk Access, but —an update: I was trying to search the ~/Library folder by selecting “Location: Active Finder Window” (the ~/Library folder being the 'active Finder window), and doing that, it didn’t work.

But using “Select…” instead, and taking advantage of Default Folder’s ability to select open windows by clicking on top of them in ‘open’ dialogs, it worked.

@cgrunenberg: I can confirm this condition here. Setting EasyFind to the active Finder window prompts for Automation access but no entry is created in the Security preferences.