Ebay plugin revisited

Almost a year ago, I posted about developing an Ebay plugin for DA. When I attempted such a plugin, however, I always got zero results (nothing in the log).

Christian Grunenberg responded that this was because all ebay results were being filtered, but this would be fixed in the next release.

There have been several updates to DA since that time, so I tried to resurrect this tool.

However, I am still having exactly the same issue. I create my plist around the following very simple EngineUrl:

I know this query works, because if I use it in my webbrowser replacing agentQuery with an actual search term, Ebay will do the search.

However, DA is returning absolutely nothing, regardless of search term. Nothing in the logs, nothing, nothing, nothing.

Does anyone have any ideas what’s wrong now?


Did you modify the excluded domains (see preferences)? Because by default eBay is excluded.

Hi Christian,

Here is my “Exclude Domains:” list in preferences:


Ebay is definitely not in there. Do you have other ideas?


As DEVONagent does not block eBay anymore, you might post your plugin and I’ll check this over here.

Thanks for responding.

Okay, first the plugin. This is the pared down version. I had something much more fancy, but then reduced it to this when I got no results.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
	<string>Searches Ebay North America</string>
	<string>Ebay Search Plugin ©2006 Morgan Giddings</string>

I still get no results (or was getting no results, until I started having crashes).

Now, Devonagent won’t run properly. It does one of two things:

  • It won’t even open a search panel. In the console, I get the error:
  • It sometimes does find the search panel (after I restart it), but then it crashes on any query I enter (and any search site):

I have done the following to try to fix the crashes:

*Removed the preferences and restarted the program
*Removed my plugin and restarted the program
*Removed both preferences and entire “DEVONagent” folder inside Application Support
*Reinstalled a fresh copy
*Rebooted (first attempt after reboot, it seemed to work, but then stopped again)

Do you have any idea what could have happened that causes it to misbehave this way? I can’t do anything with DevonAgent now…

Thanks again,

ps - I have not installed any new programs lately, and until I started testing my plug in, I never had these problems with DevonAgent.

So the crashing problem I reported in the previous message is definitely caused by the plugin somehow.

If I remove the plugin and reboot, then DA is fine, until I reinstall the plugin. As soon as I attempt a search with it, DA crashes. From then until the next reboot, it will not function correctly, even if I remove the plugin, preferences, and etc.

This is strange because my plugin has all the required fields, so it is not clear why it is crashing DA. It is also strange because the crash problem is persistent, even after the plugin is removed (until the next reboot).


I’ve just installed your plugin and run a query for “Test”. DEVONagent downloads and accepts around 200 pages and everything works as expected.

As a plain XML file can’t cause the issues you’re experiencing, I’m wondering if you’re using extensions like 1passwd or Little Snitch. In addition, how much space is available on your startup volume? You might also check the filesystem and the privileges of the startup volume.

You must have a different version.

I am using 2.2.

I have tried it on 2 different systems (1 powerpc, 1 intel).

I have made sure that ebay.com was NOT listed in the prefs.

I turned off little snitch.

There is plenty of drive space on both systems.

I removed my previous version of the plugin, and used the one I pasted above, to make sure I was using exactly the same one as you.

I get no results. On my powerpc system I am not getting any crashes. But still, no results (for the query “test”). I’m happy to send you a screen shot of the log…

If I am doing something wrong, it is something not very obvious indeed.


ps - since I assume you are doing the query from somewhere outside north america, are you sure you are actually searching the same site as me? are you sure that ebay north america is allowed in version 2.2?

DEVONagent does definitely not block eBay, no matter where you are. And I’ve just run another test using the above plugin, the official DEVONagent 2.2 release and the search term “Test” (without quotes). 203 pages were downloaded and 194 accepted. Maybe you should completely deinstall Little Snitch because this seems to be the only difference right now. In addition, please check the settings in the search window’s drawer.

I’m actually trying to get this one running also and am experiencing the same issue as the OP with regards to no data coming back. I’m also seeing this error in the console log:

11/29/07 1:08:29 PM DEVONagent[7308] DEVONagent extension disabled: unsupported browser bundle version ‘2.3’, only 2.0-2.2 are supported.

I’ve updated to DA 2.3 this morning. Has something not been updated properly?



Hi Steve,
Thanks for writing… I just gave up. Christian was indicating that it was some other problem with my configuration, but it seems like a problem with DA. I tried it on several different machines, and tried all the things he suggested.

If anyone finds a solution, I’d love to hear it - I think this would be really a great use for DA. But alas, I find little use for DA right now.



I agree that this would be great to figure out as the solution may be applicable to other plugin developers having problems. I think one feature that would be great for DEVONAgent would be the addition of some sort of debug window that could display the http interaction to determine if the plugin is actually returning any error messages from the target site. In the case of the eBay plugin, There is no log generated that I can find so I don’t know if there’s a problem with the plugin, the site, whatever…


Just send me the plug-in and I’ll check it again. But this could also be an IP-related issue - some servers send different content to different countries/languages.


The code is still posted at the top of this thread. I’ve not come up with anything else that will make this work.



I’ve again used the above plugin, no problems. Are you logged in to eBay while running the search? And are the settings in the drawer correct? Might a firewall/proxy prevent the access to eBay?

Hi Christian,

I saw that Steve did not respond yet. But I can say that I tried all those things. It is not a firewall. It is not a proxy. it is not little snitch. It is not anything specific to one machine. It just doesn’t work.

I was glad to see Steve’s posting, so that I see someone else is having exactly the same problem.

If DA had some kind of log that shows the server-client transactions, it might be possible to get to the bottom of this.


Sorry, lost track of the thread somehow… :smiley:

Given that the following modified plugin does work, I know that my login to eBay, firewall, etc… are all working okay. I just can’t seem to get the original plugin to work. As I mentioned before and second Morgan’s request, some sort of debug window or log would be a wonderful addition to DEVONAgent.


<?xml version="1.0" encoding="UTF-8"?> Description Searches Ebay North America (Title and Description) EngineUrl http://search-desc.ebay.com/_agentQuery__W0QQcatrefZC5QQfclZ3QQfromZR7QQfrppZ50QQfsooZ1QQfsopZ1QQftsZ2QQnojsprZyQQpfidZ0QQsacatZQ2d1QQsofindtypeZ0QQsofocusZbs Identifier org.alifelikewater.ebay.plugin Info Ebay Search Plugin ©2006 Morgan Giddings Name Ebay-Plugin-Title-Description Version 1.0