Edit files in devonthink to go

After being the version for my iMac, I bought as well the to go version for my iOs devices (mainly iPad) including the in-app buy allowing to open files in its origin and editing.
I tried a xls sheet and it opened in Excel however only to read and I was not able to work on it with my excel app… any other settings needed?

We are not under control of what Excel does. It’s likely you have an Excel file in an older format which Excel will report as Read Only.

but editable within the origin app should work, correct? The file was xlsx and it just opened as “read only” - I will recheck with other files, @bluefrog - thanks a lot (again :-))

You’re welcome :slight_smile:

You can’t edit proprietary formats like Word, Pages, Excel, etc. in DEVONthink To Go but they should be editable in their native applications. I saw the Read Only report in Excel with an .xls file.

A new .xlsx file worked as expected.

I tried again, after opening DTto go…

I selected the excel App to open but it just showed to me the option „to copy“ into Excel (and not to open)

Is there any misunderstanding from my side? I thought DEVONthink and DT to go are becoming some kind of synchronized finder… where I can also open and edit the documents I inserted to.


You are not misunderstanding, as what you are wanting to do is not, at least for now, possible in DEVONthink to Go. You are wanting what is commonly know as ‘Open in place’ and, unlike some other iOS apps, DEVONthink to Go limits you to opening a copy of the document in the target app. Your only option now is to switch to Excel and opening the document there by navigating to it using the file browser.

Hopefully open in place will be coming to DEVONthink to Go soon.

Thanks for answering, I bought the app and in-app features as it was written to be able to „edit“ files…
Not urgent for the time being as i am still in the introduction and learning phase…