Edit > Paste with Source Link - Only the top level domain is being copied on some sites

DT v3.8.6
Reference to new feature:

Added Edit > Paste with Source Link to include the URL or item link of the source text, if available. This command applies to plain and rich text as well as Markdown documents.

Navigated to the URL / page (MPU forums). Then, I copied the text and pasted it into a newly created RTF document. I expected the complete URL to be copied, but that was not the case. I tried this with another site (theverge.com) and it copied the entire URL.
Also, tried with this forum (discourse.devontechnologies.com), and it seems that on discourse forums, full links are not being copied. (Granted, my testing is very limited to two types of sites :slightly_smiling_face:)

Test 1 - MPU Forums

Pasted output

Test 2 - The Verge

Pasted output

@cgrunenberg: I am seeing the reported behavior after copying in Safari. The URL is clipped to its base URL - https://discourse.devontechnologies.com.

PS @hramakr : The behavior is also dependent on the browser, e.g., Opera does not provide the URL when copying, so YMMV.

New Markdown Text 1.md (2.4 KB)

1 Like

The command can only use what’s available on the clipboard and that’s not controlled by DEVONthink. Or did you browse the web pages & copy the snippets in DEVONthink?

The one that worked was copied while browsing in DEVONthink.

Internally DEVONthink adds a dedicated source link to the clipboard when copying snippets, in case of data copied in other apps DEVONthink checks the clipboard for web URLs.