Edit tags or Properties on PDF


I was looking for a software to use for organizing all my papers.
I have already a large collection of PDF files that I will be importing.
However one of the reasons for using a software to do this is the ability to tag or organize the files easily.
But for some reason I’m unable to do this with Devonthink, I’m evaluating the Pro version to gain access to the OCR functunality, to enable searc inside documents.

The reason for this is that right now I have them in folders, but sometime a file fits in several categories, so I would like to add tags or similair.
Kind of like you can do with Google Docs. (I would use this if it were not for the limits on the files and amount of pdf’s).

Why am I unable to edit the tags and properties?

Best regards.

You can “replicate” the file to another folder and it will receive that tag. Replicating functions much as an alias in Mac OSX. It makes a shortcut to the original file rather than duplicating it.

Data–>Replicate will make a replicant that you can place in the desired directory. A file is in Folder A, so it has an A tag. Replicate it and put the replicant into B. Now the file and its replicant will be tagged A and B

I prefer Replicate To that can be selected by right clicking on a file in a directory which allows one to put the replicant into the desired place via a handy hierarchal submenu.

I understand tagging and pdf annotating will be implemented in the final version. The feature has not yet been wired up.

In addition, the Information dialogue of a file offers the ability to comment and my experience is that DT searches comments.

There’s more info about those and other pending features in (at least) the Upgrader’s Guide PDF in the distribution download. I couldn’t find them specifically mentioned on any product/support pages though they might be.

Properties of RTF/RTFD/PDF documents are editable via Tools > Show Properties.

Not on PDF as far as I have been able to see.
I found the Tools-Properties, but it is not possible to change the Properties on PDF, only to view the already existing.
Also it is possible to set it on documents when you scan, but if you choose not to do so during import, it is not possible to modify them later.

I can edit within DTPO2 the following fields in Document Properties for PDFs:

  • Author
  • Title
  • Subject
  • Keywords

Select a PDF and choose Tools > Show Properties.

I’m running DEVONthink Pro Office 2.0 pb6 under OS X 10.5.8 on an Intel Mac laptop.

Check that the document isn’t locked; you won’t be able to edit properties if it is.

I can modify existing fields but not add to empty ones.

Hmm so what am I doing wrong?
I’m using DT Pro Office 2.0pb6(Not Yet Registered) On MacBook Pro OSX 10.5.8 (Swedish).

I have tried PDF that were imported directly from the web browser and finder and scanned directly from within DT.

I can Modify in the dialogue the comes up when importing from scanner, and it will be saved to the PDF.
An I can see what I wrote when I open Tools-Show Properties/Show Info.

But The only things I can modify after import are:
From Show info:
Show State
Exclude From

From Show Properties:


When I select a rich text or PDF document and choose Tools > Show Properties, the Document Properties panel opens with focus already set in the “Author” field – including cases where there is no content in the Properties panel.

So I can enter data in previously blank Properties panels. (Although, as a practical matter, I doubt that I do this in more than one in a thousand PDFs, as it generally adds no value in my databases.)

Perhaps your computer has ‘cobwebs’ in memory. Try clearing the cache in DT Pro Office and restarting the computer.

Ok so now I bought a license for the DT Pro Office, thinking it was a limitation of the Demo version, but I still can not modify anything from the show properties page.
I also tried to import a mail, convert it to RTF, and It is not possible to add or change anything in the show properties.

Another thing I noticed not sure if this is by design, but after importing a mail it is not possible to select and copy anything from it, (Like the license key for DT) :slight_smile: I had to convert it to RTF first. (I know I could just open the mail, but I would expect it to be possible to select text) :slight_smile: