Editing md and txt Documents confuses "See also" function


As I experiment currently with using md files for my notes I imported a bunch of it into a new DT database. I really like the “See also” function of DT and want go use it to gain additional insight into my stuff.

Before making a change to a md file, the “See also” works as I expected and shows me a bunch of related files. See the “See also” section for a specific document here:

After opening the edit mode of the md file with ctrl + cmd + x and only erasing an empty row, the “See also” section changes into this:

The section now shows groups instead of the last documents that were shown before the edit step of the document. Why are there groups shown now? And why does this happen even if I made no real changes to the document. I mean erasing an empty row does not change the content of the file, or does ist?

Really annoying is that the groups which are shown now are a not really suitable for the documents, so the “See also” function is not very helpful any longer…

Am I doing something wrong here? Is there something I have to configure to prevent this happening?

OS is 10.15.7 with DT 3.5.2

Thanks for reading and if you have an idea what I could change I would bei grateful to read it here!

Edit: This happens with indexed files, too. I tried this out with a test vault from obsidian. If I open the indexed md file (iCloud) and edit it in DT, the “See also” function gets confused…

I can add the following.

My second MBP (same OS, same Version of DT) does not show this behavior. Here I can edit the md document and the “See also” stays safe.

If I create a md document on machine 2 and sync it to machine 1, edit this on machine 1 and sync it back to machine 2, the “See also” on machine 2 is faulty, too. If I make the same edit on a copy of the synced md document on machine 2 “See also” is not affected.

On the first machine even a newly created md file, created with copy and paste from an unmodified md document from machine 1, gets “corrupted”.

So it seems that something is wrong with my installation or the settings on machine 1.

Is it possible to reset something on machine 1?

Today I tried working with md on my third machine. Same problem here. Immediately after creating or editing a md document “See also” gets confused and shows rubbish.

To summarize this:

  • I have two machines running the latest DT on the latest Catalina release giving me the described problem with md files. Both machines had DT 2 Pro installed in the past and got upgraded to DT 3 Pro. DT 2 was deinstalled after DT 3 got installed following the instructions I found here in the forums.
  • On one machine, which had no prior installation of DT 2, the described problem does not occur. Working and editing with md and txt files does not mess up the “See also” section. Only this one works as it should.
  • If I sync edited md documents back to the “clean” machine the messed up “See also” section is syncing back although and gets me botched results there, too.

@BLUEFROG and @cgrunenberg is there anything I can do to prevent this from happening? Some setting to reset or something else?

Any help would be greatly appreciated! Thank you very much.

I don’t see how markdown (plain text) documents would cause a problem with See Also. I have a corpus of several hundred markdown documents in several dozen groups, and See Also is accurately proposing recommended documents.

10.15.7 / DEVONthink 3.x Server.

@BurningChrome you discuss “syncing” documents – how are you syncing between machines?

You need to eliminate as many differences between machines as you can in order to test and potentially troubleshoot.

Be sure that all machines are on the same release of DEVONthink.

I suggest removing the database from all but one machine. Rebuild the database on that machine. Then test locally on that machine. If successful, sync to the second machine using recommended DEVONthink sync methods – clean the sync store first. Test on the second machine. Repeat with the third machine.

If you run into any errors along the way, stop testing and open a support ticket from that machine. Hold the Option key while opening Help and use “Report Bug”.

Hello korm

Thanks for your answer. What you proposed I am doing right at the moment. Of course all Mac machines are running the same OS and DT Version, except my mobile devices.

I sync with Web DAV, which worked flawlessly in the past.

I completely emptied the sync store and removed the databases from all machines. Rebuilding on my main machine did not work, so I copied all data over and imported it afterwards back into DT. This gave me an “indexing” dialog which rebuilding did not. Maybe that was needed? Could be an indexing error probably which gave false “See also” results?

After reimporting all data back it seems now to work on my main machine.

Now syncing to the cloud storage and afterwards to the second machine…

Fingers crossed!

Good luck … and let us know your efforts turn out :slight_smile:

There’s still the question of how the database problems started to being with, unfortunately :expressionless:


Seems it worked. Everything ist back to normal and running great on every machine. All data is there and no botched results with “See also” any longer. I wonder what caused this trouble and if it would have been possible to solve the problem in any other way…

Thanks for your suggestions @korm!

Have a nice day!