Email from Devonthink Office Pro

I updated a Mac Mini 2011 to macOS High Sierra 10.13.2 and updated Devonthink Office Pro to version 2.9.16. Now, when I right click a file and click Send by Email, a new email opens but the file is not there. This worked before the update. I tried reinstalling Add-Ons and restarting the computer with no luck. Anyone know what else I could try to get it to work?

I cannot reproduce this (same OS release, same DEVONthink Pro Office release). I do, however, notice a lag between the time the email is created and the document showing up in that email as an attachment.

I emailed what it produced to myself and found out that the attachment is in the email. I Sent by Email from Devonthink again and clicked in the email where the attachment should be and it opened up. It is in the email It is just invisible. I waited to see if it would show up, like korm said, but after 5 minutes it didn’t show so I stopped waiting.

Is this with Apple Mail as the default email app?

Yes, Apple Mail.

I’m not seeing any issues here. Does this persist after rebooting your machine?

Yes it happens after rebooting. Devonthink is the only program that does this. I added a picture that shows the file is there if the mouse is over it.

Do you use any third-party plugins for Apple Mail?

No plugins are used.

This might be another glitch of Apple Mail’s buggy AppleScript support as AppleScript is used to create the email and to insert the attachment. One workaround is to drag & drop the item onto Apple Mail’s Dock icon, this creates also a new email.

I see this ‘invisible attachment’ issue from time to time with other apps as well. It’s annoying, but the attachment does get sent, even though it’s not visible.