email import problems

I’m having two problems importing from apple mail.

First - when I open the mail import (File > Import > Email it takes forever for the messages to load in the dialogue, I’m talking at LEAST 5 minutes or more before I can see the messages that I want to import, often 15 minutes or more. Sometimes they never come up and I have to force quit Devon and mail to get them to respond again.

Second - I get lots of error messages when importing mail - all of them along the lines of "Error importing …Unsupported Content Class…

When I look at the messages they don’t look all that different from any others.

Any Ideas how I might fix/avoid these problems?

Re. 1: this seems to be the result of AppleEvent communication, we strongly recommend you use the plugin that you can install by going to Help>Install Add-ons. Basically, the AppleScript implementation of Apple Mail is hosed and the plugin circumvents that and is much faster.

Re. 2: this is happening when the MIME parsing fails for some reason. We will try to preserve as much information as possible but an error still occurred. It would help if you can send one of those troublesome messages to so we can take a look at it.

I still need some explanation – I have installed the add-ons already

  1. Do you mean that I should send mail to devon via apple script? rather than import from the devon side?

  2. I have not been able to have devon either not hang, or not crash long enough to capture an error message. I just typed what little I could read in the log window.

No, if you have installed the plugin it should work. Do you have other bundles installed for Apple Mail? Or ShapeShifter?

The message will be transferred, the error message you see is there by design. Based on the information printed you can find it in Mail and send the “raw source” to our support email address (go to View > Message > Raw Source).

I have installed the bundle it mail, several times in fact, but I have no idea where to interact with it.

It doesn’t show up in mail preferences like my other bundles do. I have mailtags and notification installed as well. No shape shifter or other them type things though.

I tried sending mail to devon from the applescript in apple mail and I don’t get error messages going that direction for some reason. The problem is I can’t tell which messages are causing the problem because devon locks up when I’m importing. Thus I cant access the error log to find out what failed. And the next time I start devon there are no error messages in the log…

There is no bundle being installed in the mail folder, and no option under MESSAGE in MAIL.

This function is absolutely critical to me. Is there somewhere I can download the add-in bundle and copy to the bundles folder in my library?

Yes, just go to Help > Install Add-Ons and select the Apple Mail Plugin. That should be it.

I have chosen the install plug-ins option five times. I have rebooted, logged out, reinstalled DTO - but nothing shows up in either MAIL or in the BUNDLES folder in the library.

Thanks for the quick reply.

Then please check the usual suspects (it checks for write permission though):

  1. Ownership of the Bundles folder (and maybe its parent), you have to own it.
  2. Check the group of the same
  3. Permissions (just to be sure)

That should fix it. Please let us know.

The permissions for the Bundles folder was the culprit. It had assigned ownership to system.


While I’ve got you - any way to assign a shortcut to that feature in MAIL so I don’t have to go up to the menu to send a message to DTO? Or to add it to the right-ciick pop up menu where my MAILTAGS options are showing?

Thanks again,

I guess you can use the System Preferences for Keyboard to assign a shortcut. As to the Contextual Menu, since this code resides in an “alien” environment I’d prefer to keep it as simple as possible to keep the number of possible “surprises” down. :wink:

once again, your advice worked – however, one problem
when I assign a shortcut to “assign in devonthink pro office”, it grabs the first one it finds which is under MAILBOX instead of MESSAGE. Is there a way to change the name (or even eliminate) the MAILBOX version and just keep the MESSAGE one?

You’ve got me there, I can’t solve this one for you at this time.

np, thanks anyway. I’m just happy to have the bundle working, I can live without the shortcut for now.

Having a similar problem, except I’m using Entourage, and there’s no handy “Install Entourage Plug-in” under the Help menu… :frowning:

I’m stubborn, but this is just unusably slow.