Encrypted DB and File—>Open Recent

DT3.0 (release). Testing encrypted database for first time. Create DB with password, add few items. Close DB, go to File—>Open Recent. DB is shown in list but selecting it results in the “bonk” sound that means MacOS won’t do that. (No error message.) Have to use the Open item and select the image in a Finder-like window, at which point I’m prompted for password and DB opens.
Intended behavior, bug, OS issue, or operator error?

There is a bug here, though I’m not seeing what you’re specifically referring to.

  1. Create a new encrypted database.

  2. Close database. Database does not appear under Recent Databases in the Navigate sidebar. A .dtBase2 file wrongly appears in the File > Open Recent menu.

  3. File > Open Database and open the database - the .dtSparse file. Wrongly, the .dtBase2 file appears in the Open Recent.

  4. Close database. Database does appear in the Recent Databases section, but File > Open Recent shows an errant folder, not just the .dtSparse file and also an defunct .dtBase2 from en earlier test, for a database that was deleted.

OK, now I’m seeing what you show above (except for the phantom deleted DB). Was expecting a XXX.dtBase2 item in the open recent menu, but not the .dtSparse version. And confirmed that I can open it in the sidebar. Not sure if the dtSparse listing was in the Open Recent menu the first time I tried it…suspect I only got to the first attempt you described.

Thanks for your prompt response…I really appreciate the support you and the team provide.

You’re welcome! :slight_smile:

3.0.1 will fix this.

Thanks for your report. I’m having a very similar experience.
Encrypted DB is shown in my list, but like you I cannot open it.
I have tried your approach, but I cannot locate an image file. Spotlight does not find the name. (More precisely, I located what I think is a relevant image, but it seems to have nothing inside it. Even from within DT.)
I don’t get any prompt for a password.

I’m holding my breath for version 3.01.

The extension of encrypted database is .dtSparse. Are you able to find it via Spotlight or EasyFind?

Thanks for the suggestion. No, cannot find a dtSparse file. But

  1. I can search for relevant individual files in Time Machine, but once I locate them, I cannot do anything with them. If I try to open them, I get the message “Database not available.”
  2. From within Devonthink, I can see the missing database in “Open Recent” menu, but nothing happens when I try to open it.
    3)When I dig back in Finder, the files all reside in a folder called Metadata.

Customer support Jim Neumann is trying to help. He wrote that Remote disk in macOS is accessing a CD/DVD drive on a networked machine. He was hopeful that DT version 3.0.1 would fix the problem. But DT 3.0.1 has not changed this behavior - I still cannot access.

By the way, Devonthink To Go on my iPad sees the database just fine!

3.0.1 did not fix this for me.
I see a folder icon (not a DT icon) and the correct name in Open Recent. The folder name is shown as Myname.dtBase2 I cannot do anything with that folder, or find it in the finder.

I recommend using encryption with caution - test before you rely on it.

That’s just an invalid recent item created by former versions. Do you remember in which folder you created the encrypted database? DEVONthink doesn’t delete databases on its own (or only via File > Delete Database…).