English Version of DEVONthink 3 contains German

I installed DEVONthink 3 on a Mac with the region set to United States and English as the preferred language.

When I right click on a file in the finder, under the services menu there is the following option in German “Zu DEVONthink 3 hinzufügen”.

I am not seeing anything here.

What operating system are you running?

macOS Mojave 10.14.6 (18G95)

Does it persist after a machine reboot?

Yes it does.

It doesn’t happen on our machines here so some setting might be involved that makes the Finder pick the German localization in the Services menu. Have you tried to rebuild the Launch Services?

Ran the command to rebuild LaunchServices to no avail.

Does reinstalling the application & rebooting the computer fix this?

The same thing happened to me: although my system is set up for United States / English, my import service is in German.

I also tried the LaunchServices rebuild, which did not switch it to English. I have not yet rebooted or tried reinstall (the full uninstall process is a bit cumbersome, so I’ll try some other things first).

At this point I wanted to respond that there does appear to be a problem.

Reboot changed nothing.

Perhaps you’d like more information from my installation as a diagnostic aid?

Note that I previously had DEVONthink Pro 2 installed, and then installed DEVONthink Pro 3.

Download a new copy from here and overwrite the existing version: https://www.devontechnologies.com/support/download

I downloaded another copy of the link you posted, unzipped, mounted the .dmg, dragged over to replace, accepted the overwrite, started the new copy, and allowed it to run (since it was downloaded from the Internet).

This fixed the service label; it is now “Add to DEVONthink 3” as expected.

I also verified with diff in the terminal that the zip I downloaded was the same content that I downloaded and installed originally.

To me this means that while there is an issue somewhere, you do not need to fully uninstall the app as per the Help instructions (which involves manually deleting lots of supporting files). Instead, you can just re-apply a fresh copy and (re)start the app.

Thank you!

Glad it’s working now.

However, I don’t know where you’re seeing instructions to completely uninstall the app.
Uninstalling and reinstalling is not an early troubleshooting technique.

Above, cgrunenberg asked

Does reinstalling the application & rebooting the computer fix this

For me, uninstalling “rigorously” means uninstall, then install again. So I searched for uninstall through the DEVONthink Help menu and was pointed at its Getting Started guide. It had instructions for full uninstall, which also included, for example, deleting ~/Library/Preferences/com.devon-technologies.think3.* and suchlike.

Yes, there is exaclty the note:

Note: In troubleshooting situations, please do not uninstall the software without talking to our support team beforehand. Most issues can be resolved without uninstalling the software.

Which is why I reached out originally.

Ahh… yes, I personally would take “reinstalling” to mean “download and overwrite the current application” unless pecifically instructed, though @cgrunenberg would have to clarify what he meant.

Indeed. That’s why I try to be very pedantic about exactly what I’m trying or not, and ideally why. Anyway, I think this about does it for this issue, at least for me. Again, thank you for your help and attention! Over and out.

You’re welcome :slight_smile: