Error downloading DT Personal 2.7.4 update

When I try to update from DEVONthink Personal 2.7.3 to 2.7.4 from within the application, the download process stops and this message appears: “An error occurred while downloading the update. Please try again later.” I have gotten this result many times over many days.

What is causing this problem? How can I fix it?


Just download a new installer from here:

Just tried three times. Each time, the download fails with the message that the network connection was lost. But my network connections seems sound. Another, smaller download was successful during the same time that the download of DT Personal was unsuccessful.

It worked on the fifth try.

Ahh, the myth of the “persistent network connection” continues…

It is best to think of the network as a traffic grid. Sometimes the streets are empty and you can get 'er up to 60 in 2.9 seconds (in your Lamborghini Veneno, of course 8) ), and at others you are hopelessly gridlocked. Networks are the same way… with a lot longer roadways and a bunch of toll booths and checkpoints along the way. :mrgreen:

PS: This is meant very tongue-in-cheek (while still being truthful). No offense is meant by it. :^)

Yeah, but it’s still unusual for the download of one moderate-sized filed to fail ten or more times in a row when other downloads work fine.