Error message >> DTTG2 as Document Provider

Hello - anyone else seeing this?
Just checking if necessary to start a support ticket…

Updated a few minutes ago - met with the following pop-up message on starting the app for the 1st time since the update:

Error. Database store couldn’t be moved to its new location and so this app cannot act as a document provider. Please synchronize all changes, delete this app, and reinstall it.


New to me. Did you Sync, delete and reinstall it?

This message appears when DTTG2 wasn’t able to move the database from the Documents folder to the shared app group container which is necessary for the document provider extension to get access to the database.

Could you please send us the logs that DTTG2 provides when you use ? > Contact Us? We’ve seen it in our beta test phase only once so far.

Needed to jump through app-store hoops to get it installed in the 1st place, so trying to avoid this if possible. :neutral_face:

Will do!

[Edit:] Just did.

Just got the same error on my phone-wasn’t an issue with the beta. Logs sent.

Yes. I am getting it also.

Delete and resync…Arrgg… I have 10 databases, for a total of over 11.5G on two separate mobile devices. That is a time consuming process.

UPDATE: Received the message on my iPad pro. Did not receive the message on my iPhone 6.

Deleting the app and reinstalling did not help. I still get the error, even though no databases have been synced.

Curious, I didn’t have a problem with my iPad-just my phone.

If you must re-install the app, for now you will get version 2.0.8. Immediately check for updates and install the 2.1 update without first launching the newly installed 2.0.8. That process has worked for me. If I installed 2.0.8, launched it, then updated to 2.1, I would get the error message.

OK, thank you for the logs. It seems this issue is only hitting beta testers who had previously installed version 2.1 and are now, why ever, receiving version 2.0.8 from the App Store. This creates a new database in the old location and causes confusion. We’ll submit a version 2.1.1 soon that will simply suppress this error message and use the correct location.

Hmmm… not sure about the “receiving versions 2.0.8” comment. I am having the problem on my iPad Pro. Version shows as 2.1. Downloaded from app store via “updates”. And I was not a beta-tester.

Hi, I see the same behaviour as the previous poster: My iPad Pro shows the mentioned error message, my iPhone 6s does not. I was not a beta-tester. Cheers,


Apple definitely caused some issues here by delivering version 2.0.8 to people who already had 2.1 installed (and so an already moved database package).

Version 2.1.1 is already in the beta review queue. If someone of you with this problem would like to try the beta please drop us an email to dev-ios(at) and we’ll send you a Test Flight invitation.

Just want to chime in here, in the event that it might assist in finding any issues - whereas I was an initial Beta-tester, I pretty much moved over onto the stock-appstore version, as soon as it was released.

Certainly haven’t had anything Beta-related involving DTTG2 easily since the last few months of last year…
This might have been enough to trigger the issue - but regardless, just figured I would add the above.

Personally, when I beta test DTTG I first delete the public version, reboot, then install the beta from TestFlight. Go through the beta process, updates, etc. When I’m ready to resume using the public version, I delete the beta, reboot, and install the public version from the App Store.

Yes – this means completely reconfiguring DTTG twice. However, I have never had an issue. I follow this same process with anything I beta test (unless there has never been a public version, e.g., with Quiver). I’ve always found for all releases of iOS that having two versions of the same app causes trouble. No different than macOS where having a beta app next to a public version can cause confusion for OS X/macOS. The safer-than-sorry rule applies.

I also follow a delete and reinstall procedure between beta and public releases and rarely see issues.

An update to version 2.1.1 is ready and waiting for the App Store review. It should fix the problem without having to delete-and-reinstall. Sorry for the inconveniences!

I do as well - certainly did with DTTG2 (from Testflight to Appstore version) - which is why I find it strange that I too was hit by the bug. Regardless, the fix is pending, so no harm, no fuss!

Thanks for jumping in so quickly with a solution. 8)

The bugfix release 2.1.1 is has already passed Apple’s review. They’ve become really quick 8)

I had it too on the iPad pro but not the iPhone 6s. Did the reinstall and it worked afterwards. No beta testing here.