Exclude Links not working, or wrong syntax?

I have the following line in “Exclude Links” in my custom search set:


And yet results that match this criteria (say, example.com/topic/details/1234/string) are still showing up. Any idea why?

I cleared the cache to see if that would help, but it didn’t. Am I using the wrong syntax or otherwise misunderstanding the setting?

Wildcards are currently only supported at the beginning or end, e.g. substring, prefix* or *suffix.