Failed Database Verification DTTG 3.5

Having updated to DTTG 3.5 I’m receiving a sync-log message “Failed database verification, please repair the database” for one of my databases. The log reference console.log on the iOS device, and that contains these two messages:

DEVONthink[34562:3394946] VERIFY: Content missing file path: NameOfDatabase:/Path1/Path2/NameOfAFileWithoutSuffix/
DEVONthink[34562:3394946] VERIFY: Files app > On My Device > DEVONthink > Console.log
DEVONthink[34562:3204796] SYNC: Failed database verification, please repair the database.

If I navigatee to that record (a Word document) in DTTG, the screen shows

Word Document
Download (118 KB)

Tapping on Download briefly shows an error message Couldn’t download document

If I navigate to the record - which is indexed - in DT, then the record is present, shows a preview, and Show in Finder correctly shows the file in Finder. If I verify the database on DT, no problems are reported. This database is synced via Bonjour only. The same error does not occur on a second iOS device.

How do I repair this, please? Running the Fix and resync commands didn’t help.

Did you long-press the database in DEVONthink To Go and choose Verify & Repair?

FWIW, had the same issue. DB was correctly verified on DT3, but DTTG 3.5 was having none of it.
Did not occur to me to “verify” on the iPad (actually forgot I could, via the long-press). Didn’t immediately work, but did it a few times with the problematic DB in DTTG, and seems to have sorted itself out now.

Syncing completing, and no errors.

1 Like

iOS and “discoverability” :face_with_monocle:


No, and I misunderstood the manual to say that the Fix command was used to verify & repair; Discoverability… anyway, that command actually did solve the problem, thanks for pointing me in the right direction. Sadly it did not solve the problem which I seem to have caused by using the resync command, which is that I now have oodles of missing manifest errors for my cloud sync location when syncing the iOS device in question with the cloud sync store. No errors appear when syncing other devices with the same sync store.

The location verifies without error using verify quickly from my Mac, and shows two download errors when verifying thoroughly (an error number much smaller than the number of errors shown on the iOS device). I will clean the location and return here to report success or request help.

Cleaning the location seems to have solved that second problem, so all is well. Thanks for your support, Jim.

1 Like

You’re welcome :slight_smile: