Failure of Search to find documents from main Inbox

I can scan a document, from HP Officejet Pro 8500, import it into the main inbox using OCR, then copy to a sub folder, no problem so far.

I can open the document choose a word most likely only found in that document, highlight it, look it up in the dictionary, get a definition no problem. So the OCR has worked fine.

However go out to the main inbox and do a search for the same word and the document cannot be found. Go to the previously mentioned sub folder and do the search again, and hey presto it finds the document. What am I doing wrong? Am on 30 day license trial. There are no tags or other info attached to the document. I just think that if the dictionary can find the word in the local folder, should the search not find it after looking through the whole database?

Do you use the toolbar search or the search window? And which search settings do you use?

Many thanks for your reply. I was using the search window only, it was set to
“all”, “prefix while typing” and “in selection”.
I didn’t realize there was a search on the toolbar, I have tried it and it works very well, even on scans that are not the best reproduction.

So docs that can’t be found using the search window, even if just set to “all” is selected, can be found no problem using the search option on the toolbar.

I can live with that, it would be nice to know why though?, and if there is a way around it?

The difference might be the “Prefix while typing” option of the toolbar search whereas the search window is looking for complete words by default. Just use the ~ operator (e.g. ~word) or wildcards (e.g. word* or *word) to search for substrings, prefixes or suffixes in the search window too.

Many thanks for your reply. I have tried all your suggestions, but to no avail, it is still the same.

In the meantime I have loaded up the latest version of DT, still no difference.
I get the feeling the the search option is simply not looking at the specific database in which the document I am looking for is situated. I say this because if I go into the said database and then perform a search, Search finds the document. So the trouble might be the way I have the files and folders arranged, don’t forget I’m a newbie and I might have set it up wrong.

The problem still remains that if i do a search from the global inbox I can’t find the document, if I use search from the tool bar it works fine. This is not a show stopper but it would be nice if it worked ok, it just leaves me doubting the software a little bit?
best regards,

Could you please post screenshots showing both approaches (“search from the global inbox” & “search from the toolbar”)? Thanks in advance!

The Search window (Tools > Search) allows one to search across all open databases or only within a specified one (or even limit a search to a chosen group). Take a look at that setting, as I suspect that’s your issue.

I always use the full Search window, not only because all the settings are easy to inspect, but because it provides a number of features that are not available in the little query field on view windows.

Hi Christian, I have attached two screenshots as requested, hope they shed some light.


Main Search Window.tiff (171 KB)

LorconblueToolbar search window.tiff (133 KB)

Hi Bill,
it is in fact the full search window, (not the tools>search) window that is giving me the trouble. I cannot find the files with the main search window.
The toolbar search window works fine.

The Tools>Search window is the full search. Unless I’m missing something, it would appear from the screenshots posted that the file is not found in the toolbar search window? If indeed it is a search from the toolbar that is not working, this is the type of screenshot that you want to post so that we can see your search criteria.

Please see attached screenshot of toolbar search option

Toolbar search window.tiff (133 KB)

Please ignore last post, wrong screenshot attached, will resend.


Correct file, search window.

corrected search window.tiff (370 KB)

The option you have set for searching from the toolbar is ‘In Selection’, and you have the Global Inbox selected. In the picture that you posted of the Main Search window, all 4 of the documents returned in the search are not located in the Global Inbox.

Just to also clarify further, searching in the toolbar will not locate documents in other databases, even if ‘In Selection’ is unchecked. I like to think of the Search window as a means to ‘filter in’ results while the toolbar search is a means to ‘filter out’ results. As example, if I want to search all my databases for the word ‘flue’ and I don’t know where the documents may be located, the Search window can help me find the term, even across multiple databases (filter in). However, if I have a particular group selected in a database and I want to locate the term ‘flue’ only in documents within the selected group, then I’ll use the toolbar search (filter out).

Thanks, Greg, but I have tried every combination of search criteria from the toolbar menu and nothing works. I have also notice that while the word “search”, just underneath the search window is not greyed out, it doesn’t start a search process when clicked, it does nothing, you have to type in the word you are looking for and press return, not sure if that is normal, I don’t really think so. I think clicking on search should start off the search option.

First, move (or create) a document in the Global Inbox that contains the word ‘flue’ and try that again, using the option ‘All’.

Also, if you don’t want to type return to start searching, check ‘Prefix while typing’.

Your screenshots of the full Search window do not display (at least on my iPad) all of the settings in the left column.

I’ll guarantee that you have enabled a setting that is filtering out the search improperly. Are all open databases being searched, or is the search restricted to a database or group in which no items meet the search criterion? Have you inadvertently filtered by Label or Lock state? Is a filter in the Advanced button? If so, click on the Reset button to clear it.

The full Search window is more powerful than the little Search field in a view window, not less powerful.

Hi, Bill, thanks for the reply and having the patience to answer. I’m sorry but I’m totally confused between the two search options. I think maybe I am calling them one thing and perhaps you are calling them something else.
To me the Toolbar Search option appears at the very top of the Devonthink bar at the top of the screen, it has to be opened by going to tools>search.

For the want of a better word the other search option is the General Search option that is visible all the time on the Devonthink screen, located at the right hand side, I simply type in a word and hit return.

It is the General Search option that doesn’t work for me, apart from the drop down menu I can see no other options to select filters or database choices, on that drop down I simply select “all” and do a simply word search.

I have attached a screenshot to explain where I am coming from.
Many thanks.
works perfectly.tiff (461 KB)

You are using different terms for the search options than what we are using. The toolbar search is in the toolbar-the area to the right of the ‘i’ Info icon in your screen shot. The main search window opens in its own window, and is initiated from the ‘Tools>Search’ menu.

The main search window is the more powerful, more inclusive search option (Tools>Search).

The toolbar search option is less powerful, less inclusive. The search results that you have posted are the expected behavior. The toolbar search did not located what you wanted because you had the Global Inbox selected, and you were searching for documents not located in the Global Inbox. You need to use the Main search window (Tools>Search) to span a search across multiple databases. Re-read my post above that begins with ‘Just to clarify further…’.