Feature request: YYYYMMDDHHMMSS tag for Wordservice

When using DT Pro, I frequently use the wordservice date/time shorthand to get a timestamp into a file. Now that I am expanding to Zettelkasten, I’ve found a conflict between a date/timestamp to use in my texts, and a date/time stamp I want to use as reference or tag.
This latter timestamp would be YYYYMMDDHHMMSS - without any special characters added.
Would it be possible to add this as a special date-time tag to wordservice?

Thanks for the suggestion, a future release might add this (but freeware has always the lowest priority by far). What about using a script which inserts the timestamp via the Scripts menu (and optionally with a shortcut)?

I use an Applescript to format the date to my requirements
Just curious, where are you storing this date key? How do you use it?

I prefer wordservice to Script, it simplifies my setup and reduces all the things I have to remember. Plus, maybe it is just me, but I’m always struggling to get Scripts and shortcuts to play nice…

Inside DT I use it as a marker inside the file, then copy and paste where necessary.

Outside DT I use it to document and log changes in code and latex, but I’m tired om managing shortcuts all over the place (see also my remark in my poor ability to get Script and Shortcuts to work).

This kind of thing is easily accomplished on your own, via scripts, etc. If you’re having issues with our scripts, please clarify what your issues are.

In a Shortcut that gets the value on the clipboard…

PS: Unzip and put this in ~/Library/Services
Zettel Date.workflow.zip (80.3 KB)

Thanks for this, really useful - on Monterey I have the shortcut working from the services menu - still figuring out how to get they keyboard shortcut to work

You’re welcome :slight_smile:

still figuring out how to get they keyboard shortcut to work

  • What’s the issue with the keyboard shortcut?
    • Where are you setting it?
      • After setting it, did you confirm it is set in the Services menu?

I have it working in DT now, both through Services and keyboard - apparently I had a shortcut collision with my preferred shortcut (ctrl-command-T).
Other applications are still a bit troublesome, the shortcuts are not always visible in the services menu

I’m setting everything through the System Preferences panel, as per the recommendation

Small correction to Format String, for everyone’s benefit, it should be:
YYYYMMddHHmmss

(changed DD to dd)

DD is the day of the year.