File restore from Time Machine

I am trying to restore an .xls file I accidentally altered, saved and finally deleted in DT3. The

DT3 is installed on an MacBook. I have an Airport Time Machine so I tried to restore a previous version of that file prior to the point in time I had altered the .xls file. I could locate several versions of the respective file with different saving dates on the time machine. I had chosen the one last saved prior to the altering moment in time and restored it.

The system asked me “An item named “CC67E478 …(original).dt3” already exists in this location. Do you want to replace it …”. I did both. Either replace or keep both did not work. The restored file was the same altered I had prior.

I tried several times, no changes. I thought it could be as the “original ALTERED file” is still in DT3. So I moved it out of DT3 to the desktop, no changes and finally, I deleted the file (Keeping a copy on a USB stick).

I was not able to restore the file from a previous copy in Time Machine. Is there a clitch or did I do something wrong, in the wrong order? I have been reading in the forum and found the following:

1. Control click the file to restore, and chose the “Restore to…” command. (Time Machine inserts the selected document’s name in )
2. Time Machine will exit and a Choose Folder dialog will open with the instructions at the top: “Select a folder for the restored items”
3. Browse to a location outside the database package and press “Choose”

Be careful to use “Restore … to” from the contextual menu and not use the Restore command at the bottom of Time Machine’s window.

I have no option to restore the file by using Control Click … Anyone having an idea?
Thank you

This is not the actual file but just one of DEVONthink’s Spotlight index.

Thank you. So I guess I am doing something wrong. Can you tell me what I am doing wrong?

That’s a question for @bluefrog, I never had to restore Time Machine backups as I prefer my own ones.

I managed to get it done. Restored the whole DT3 database and copied somewhere else. Opened it with DT3, selected the file to restore and extracted it and pasted the restored file back in my former database. It’s somewhat belts-and-suspenders and cumbersome but it worked.

I don’t remember if Microsoft Office is compatible with previous versions, but perhaps next time best approach could be trying to restore a previous version from inside Excel…

Thank you for your suggestion. I actually would not know how to do that in Excel and not sure if possible. The .xls file needed to be an older version. A version prior to me saving the .xls file after I had deleted parts of it. Not an older Excel version … if I understood you correctly.

1 Like

Since DT does provider file versioning, I use Time Machine to keep different file versioning.

Recently, I make some changes in a Markdown file, which I didn’t want. I wanted the previous version. I went to Time Machine to find the previous version and restore. It ask if I want to Replace, which I answer yes. In the Finder, the file was replaced. In DT, the MD file is still the old file.

I even try shutdown DT and restart DT. In DT, the MD file still shows the old file. But in Finder, it is the replaced file.

If you open the MD file in external editor, it is the replaced file. If you located the file in Finder, it is replaced file. If you view in DT, it is still the old file, not replaced.

I do a File integrity check, it shows the file is Invalid File integrity, checksum is different.

So, how can I do a proper file restore from Time Machine?

Does what @Jj67 above reported work for you?

I don’t need to restored the whole database. I have already successfully restored the file to the location in Finder.

Oh. Was trying to help by answering your question best I could.

You made that clear. But the way proposed by @rmschne might be the best choice you have. Alternatively, you could just restore the missing file to another location (i.e. not into the DT database!) and import it into DT from there. You must not restore a file directly into DT’s database because DT maintains all sort of information about the files it stores – those would not be correct when you directly put files in DT’s database.

This is somewhat confusing. Are you talking about an indexed file, i.e. one that was never imported into DT? In that case, you might want to try to “update indexed objects” from the “File” menu (I don’t know the exact term in the english version, it’s the entry below “Index files and folders”) .
If, however, the file was originally imported into DT, the description makes no sense. Time machine should effectively restore it into the DT database where it originally was, not somewhere else on your Mac.
So showing the complete path to the file might be helpful, I think.

1 Like

The file is in the DT’s database.

In order to restore from Time Machine. I use Data->Show in Finder. With the file selected/highlighted, I Enter Time Machine. I browse through Time Machine to select the file I want (Time Machine keeps a few versions of the file). I click Restore. Given a dialog of Keep Original, Keep Both and Replace. I chose Replace.

The file in Finder was replaced with the version I selected. In that case, this new replaced file was never imported into DT.

Under your advice, I do Update Indexed Items. It works! The new replaced file is correctly shown in DT. And I do a File integrity check, it no longer has Invalid File integrity, checksum is different error.

With these steps, is this new replaced file part of my DT’s database even though I didn’t explicitly imported in?

You still did not show the complete path to the file.

I assume that the file is only indexed and not imported because everything is fine after you updated the index. But only you can tell that, since my crystal ball is in repairs.

Please read the relevant chapters in DT’s documentation on “importing” and “indexing” or search in the forum – this topic has been discussed ad nauseam and there’s little point to repeat everythig again.

1 Like

Is this what you are looking for for complete path to the file? I hope I have provided the correct info.

Screenshot 2022-03-01 at 6.36.56 PM

Seems to be, and it also says “Files.noindex”. So I have no idea why “Update indexes” solved your problem, but since it did, you should be fine. Next time, though, you should really restore from Time Machine to another location (like Desktop) and import the file into DT from there. That’s simpler and not as error-prone as your approach.

1 Like

It doesn’t. The file is inside DT database, and DT is right in claim the file has bad CRC, because it has been modified externally by other program.

A 101 thing: Do-not-touch-inside-DT-bundles. Or you close DT and restore the entire database, or you restore to an external folder and then replace the file via normal ways: delete old one, import new one.

Any other way to do it is a warranty to disaster.

Edit: if you want to modify a number inside Excel, you open Excel, modify it and then close it, nor open the saved file, find the number and then modify it.

1 Like

This is exactly what I did.
The file was originally imported into DT. Time machine effectively restore (and replace) it into the DT database where it originally was. Not somewhere else on my Mac.

And yet, somehow, DT didn’t ‘refresh’ (or index) it? It still show the old file. Despite, at Finder level, the new file has replaced the old file. It even resulted a File Integrity error.

But somehow, the Update Indexed Items fixes all these problems.

You are right that why “Update indexes” solved the problem. I did a few more testing with restoration. The “Update indexes” does not solve all cases that I tested.

Somehow the Time Machine can only restore to the same location, not another location. But I will choose “Keep Both” instead of “Replace”. This allow me to import the restored file into DT from there. This method is proven to work in all cases of my testing.

Thanks. I have establish the flow for file restoration. I will restore the file, instead of replace the file, into the folder (no choice of folder from Time Machine). Then import the restored file, delete the old one, within DT.

1 Like

I can restore to any location I want, using the context menu:

You should really do that (i.e. restore a file to another location) and then import it into DT from there. That way you avoid disturbing DT’s internal structrues and you don’t need to run update index.

2 Likes