Files will not download in DTTG3

I am a new user to DT3 and DTTG3. My files are syncing correctly between the applications and I have DTTG set to download on request. In DTTG I see the thumbnail of my files with a link to Download. When I select the download link, I get a short spinning wheel but the file does not download. I am using CloudKit.

Welcome @Uptheroad

Are these imported or indexed files?

Both. I didn’t have the problem initially. I’ve even deleted and reinstalled the mobile app to include data, reinstalled and resynched. Attached is an image of notifications.

Deleting and reinstalling has no effect on the sync data. It is independent, just as your databases are independent on each device (i.e., you deleting DEVONthink To Go had no effect on the databases in DEVONthink).

You need to clean the sync data and resync.

I’d do this on the Mac as you know (I think :slight_smile: ) the database is intact there.

In DEVONthink’s Preferences > Sync, select the sync location, then Control-click the database in the Databases list on the right, and choose Clean Database.
After the clean is successfully reported in Window > Log, enable syncing it again.

The Clean Database is grayed out


I’ve solved my problems by deleting all the sync locations on my devices and starting over. I realize it was probably the long way but it worked. I appreciate your efforts and quick responses. I think I’m going to like Devonthink.

Glad to hear it and you’re welcome. Thanks for the follow-up.