Firefox Clip PDF and PDF in general

Hi, I just gave DEVONThink 3 a try.

In less than 5 minutes I stumbled upon:

  1. The Firefox extension does not seem to be able to clip PDFs
  2. DEVONThink asked me to remove an Adobe PDF “Internet Plugin”
  3. When using Chrome I could clip the PDF but it was shown as just a black document

Any other tool I tried in the last weeks (Pocket, Raindrop dot io, …) had no problem to clip/bookmark a PDF.
I know I am comparing apples to oranges, but I wanted to step up from a bookmarking/read-it-later service to DEVONThink and I am completely disappointed.

I found some issues describing the above issues here, but since I will now deinstall the app, I just wanted to at least give you this feedback.

Kind Regards

DEVONthink is a deep app with myriads of features, unfortunately you immediately stumbled across things that either occur occasionally or that DEVONthink afaik isn’t responsible for.

I can only say: don’t deinstall it but take the time until the demo expires to thoroughly explore it.

There’s more than one user who came here after testing DEVONthink years before and who now regret it that they didn’t look close enough.

Thank you for your reply (I mean it, I don’t try to be “nice”).
I even took the time to get rid of the black PDF display (I needed to uninstall another “Internet plugin”)

But DEVONthink does not do the most basic thing I expect it to do: Allow me to clip PDFs from within my browser. So even if it offers something else: it should be easy to find and recognize – even if it takes time to master.

Stumbled how?

Note: Browsers are continually changing their codebases as this can affect the behavior of extensions (and in some cases, completely disable them).

Have you tried setting and using a hotkey for Preferences > Sorter > Clip to DEVONthink?

I understand your complaint. On the other hand I can clip PDFs from Firefox to DEVONthink. Not that I do it often as Safari is my main browser.

It is important to know that every web page behaves differently and I have not found a single app that handles all of them perfectly. And I have tried a lot.

So when you test the clipping feature (of any program) you should try it with lots of different web pages. In case of DEVONthink ticking the clutter-free box often makes the difference. Also you could use Print/Save as PDF to DEVONthink as an alternative. Or more precisely as two alternatives, with or without Reader view. Which works best depends on the page and on its content because clutter-free and Reader view work best with text-heavy pages.

Another thing are ad block and pay wall blockers. While Firefox might be able to handle them in general or because a cookie had been set the webkit framework DEVONthink (and Safari) uses does not (yet). That’s one of the reasons I mainly use Safari.


I installed the Firefox extension and clicked on the icon it installed. Tried two different PDFs.
Nothing happened. No error, nothing.

Have you tried setting and using a hotkey for Preferences > Sorter > Clip to DEVONthink?

No, sorry.
I really expect such things to work. I really have removed DEVONthink from my computer

As you wish.
Have a good week!

You are far more patient than I…

That said, I’ve noticed the same behavior with Firefox. If I am viewing a PDF in the browser, click the “Clip to DEVONthink” extension, nothing happens at all, not even an error message. Of note, Evernote also has not been able to directly clip PDFs from Firefox for ages, but it did give an error message–something along the lines of “this site doesn’t allow that”–but it was consistent across any PDF viewed in the browser.

I don’t use a hotkey for the Sorter, but clicking the sorter in the menu bar, and then the Firefox icon correctly imports the PDF to DEVONthink.


Thanks for the URL to test.
Would you mind trying the Sorter hotkey too, just to verify the correct behavior? Thanks!

et al:
Firefox is using PDF.js as the renderer since FireFox 19. This is likely why it’s not working with the extension button. Use the Sorter directly or a Clip To DEVONthink hotkey for now.

Yes. Works as expected with the Sorter hotkey.

Firefox 86.0.1
macOS 10.15.7
DEVONthink 3.6.3


1 Like