Font preferences.

I was trying to set the preferences for the fonts that I prefer (particularly their size).

But the Select button in the Edit section of Preferences doesn’t seem to do anything.

The font/size settings in the Edit section of Preferences affect new text that you type into a new rich or plain text document. They do not affect existing text, as that would be generally undesirable.

I’ve got Times 12 as my rich text font. True, that size font would be hard to read onscreen. I chose that for print output. But DT has a ‘magnify’ feature. Place the cursor focus in a text document and press Control-Command-Up Arrow. The apparent size of text increases, but the font size setting hasn’t really changed. And DT will ‘remember’ your magnification setting. That’s great, as a couple of key-presses make my documents easy to read. (If you overshoot on view size, Control-Command-Down Arrow reduces the magnification.)