Footnotes and RTF?

This might have a simple answer: why doesn’t DEVONthink Pro RTF support footnotes?

Exporting a file from Mellel (which uses footnotes) as RTF, I can see the footnotes when I view the file in MS Word. In TextEdit (or Pages or PathFinder), however, they are simply not there. DEVONthink does not show them either.

If DEVONthink uses Apple’s engine for RTF import and display, then I’d complain to Apple. If not, I’ll make a request here.

Since RTF is a documented format, and this appears to be part of the format, I’d really, really like to see it supported in DTPro. I could kludge my way around native support for the Mellel format if I could just get footnote support of RTF.

I’m afraid you have to send your request to Apple because we are using the Apple text engine that deals with interpreting RTF. Basically, if it doesn’t work with TextEdit it won’t work with DT Pro since TextEdit is the showcase of what Apple’s text engine can do.

Also, from experience I can say that the RTF format used by different applications is not always documented and is really difficult to interpret since it can be expanded with arbitrary definitions that may not be compatible with other programs.

Is there a reason for not using PDF as an export format from Mellel? That way, you will see the proper formatting and you could still copy information out of a document (just not edit it).

The support of /footnote is documented in the standard, but it, like tracking changes (also in the standard) are things which Apple has chosen to ignore. I sent 'em an email, but I’m not holding my breath. At least your answer really was easy.

As far as the Print to PDF answer goes: it’s fine, but not ideal. It’s a slower process, but survivable. There are two (minor) problems:

  1. PDFs are not editable. So (for instance) a handout for my students will need to be re-created next term since sometimes cutting and pasting screws with layouts, fonts, etc.

  2. Footnotes are not preserved as footnotes. They’re just text. Which is better than nothing, admittedly, and I do at least get them in the DT database for indexing (which is itself not insignificant).

So, yes, I have workable solutions. They’re not perfect and there’s some redundancy. Until Apple can support RTF more fully (or DevonTech and Redler come to an agreement) I’ll have a workable-but-not-ideal solution. I can live with that (because there’s no alternative! Curse you makers of exceptionally good tools!)

Two more suggestions:

  1. It would also be helpful to contact Mellel where you request more interoperability with other Mac programs such as DEVONthink Pro. As Christian reported on the forum in an earlier thread, they were not very interested in this. But I’m sure they’ll change their minds when their customers ask for it. One hint for them: Open Office XML format…

  2. With regards to your editing: you could take the URL to the file of the original and attach it as the URL of the record. That way it’s rather easy to open and edit the original. You’d use a “file://” URL type here.


FYI: This is now part of version 1.0.2 of DEVONthink Pro when you install and use the PDF Services scripts.

Annard, I seem to have failed to do what you describe in this 6 month old post.

Let’s say I’m working on a mellel file. I save it, then go to print, choose PDF, and choose one of the two devonthink scripts. It sends the PDF to devonthink, but in the Path field it just points to its place in the database (under finder of course), and there is nothing in the URL field.

What i understood from the old discussion – which would be a decent workaround for now – is that it will somehow point automatically to the original mellel file in the Finder.

Or was I dreaming? :wink:

Would this change something in regard to DEVONthink compatibility?

In response to the last two posts:

Talazem: please make sure you’re running version 1.1.1 and also make sure to invoke the “Help->Install Add-ons…” menu. This will (re-)install existing scripts. The latest version really will set a file URL for a new record that should point to the original file (if that information can be retrieved by AppleScript from the “other” application).

louise: XML is unfortunately not a panacea. It’s just a standard way of describing arbitrary information in an expansive way. Since the people behind Mellel seem to use yet another description for a document, there is not much we can do. That’s why I wrote earlier that it would have been better if they would have used the Open Office XML format, since there exist ways for displaying that format in HTML.

I did what you said. It worked. And it was already working before, but the problem wasn’t the scripts, it was what I was printing the PDF from: Mellel. Apparently Mellel is not script-friendly, i.e. that information can NOT be retrieved by AppleScript from the “other” application.

Trying from Omnioutliner, it worked fine. Thanks for the help.