Frontmatter syntax in MultiMarkdown?

When using frontmatter in Markdown files, I noticed DT and DTTG won’t render the first line directly after the second set of ‘3 dashes’. But it will render if there’s an empty line between the dashes and the rest of the content. I can’t find if this is according to MMD spec or an error. A linebreak is not needed in most other Markdown related tools I use.

Is an empty line break after the --- necessary to render content?

This does not render “Content”

---
title:Test
---
Content

This does render “Content”

---
title:Test
---

Content

This does render “Content” over here. I have hidden preference IndexRawMarkdownSource enabled - maybe that’s the difference?

In generalizing my example I missed an important point apparently - the fact that I’m using something which MMD recognizes as metadata fields.

This does not render “excerpt:: Content”

---
title:Test
---
excerpt:: Content

This does render “excerpt:: Content”

---
title:Test
---

excerpt:: Content

This is what I’m actually using. And thanks to @pete31’s pointer it seems I’m ‘interfering’ with the MMD metadata field spec (I’m using these fields for Dataview in Obsidian). Apparently this is what MMD spec requires (see below). I’ll find a way around it. I’m not a fan of the MMD spec, but at least I found out what my ‘problem’ is. Thanks for the hint @pete31.

(via: MultiMarkdown Syntax Guide - fletcher/MultiMarkdown Wiki)

3 Likes