Full Screen Font Display

I don’t often use “full screen” display in DevonThink, but thought it would be a good solution to a problem. But the display text is too small. I have gone to Preferences > Editing, and changed the Full Screen font to a very large font.

But it doesn’t use that font in display. No matter what it uses the same display for rich/plain text that are indicated in preferences. When does the Full Screen font come into play?

I’ve always had a lot of problems figuring out what the font was or wasn’t doing. It testing the options while prepping this note, I changed the font for rich/plain/display text and after changing, the display didn’t update the first time. It only updates the 2nd time I modify the font. Also curious.

While I’m at it a long-time curiosity is that I print a document and see in preview that the text is tiny. So I go back to the document and hammer on Format > Font > Bigger six or seven times and attempt another print. Eventually the preview indicates a “normal” print appearance and I go ahead and print.

So those are my difficulties. If you can direct me to anywhere in the manual(s) I can find a complete explanation of the relationships between print and display font sizing that would be great.

– Gerry

Hi Gerry. I know that there is an Applescript available somewhere on this forum or from the DT website that provides a usable workaround for font control when printing.

Agree with you 100 percent about the other issues you mention with respect to full screen operation, and I hope that the developers have an adjustment scheduled for a future release. Thanks for your post.

Most of the time when I need to print a text document I also need to add header, footer, footnotes, etc so I simply copy it into the clipboard and paste it into a more full-featured word processor, e.g., Pages.

But here’s a kludge for a quick printout of a DT text document, with reasonable left and right margins and font at more or less correct size: open the document in its own window and resize the text width to about 5.5 inches.

There are scripts in the DEVONacademy section to do some layout of text documents. See ‘Scripts for Dealing with Rich Text Documents’ at http://www.devon-technologies.com/support/academy/dt_scripts.html. I’ll confess that I haven’t tried them.

Are there any updates for this issue? It’s hard viewing text in full screen mode that is 12 point. I’ve got Full Screen set to 48 point.

10.5.8, 2.0b7

Jeez! Come on DT guys! Is this ultra-simple problem really being ignored?

I can’t believe one, simple text-zooming problem has stumped you all.

If you can’t code-in a typeface change, at LEAST let us zoom in!!!


Your Buddy

I use as the default Times 12 point. On my iMac with 27-inch display, that looks tiny at actual size.

Control-Command-Up Arrow zooms in (magnifies) the view without changing the actual font size setting. Control-Command-Down Arrow similarly reduces the apparent size. Continue holding down the Control and Command keys and press the Up or Down arrow key repeatedly until the font size is comfortable to read.

DEVONthink remembers the magnification setting, whether it was done in normal or Full Screen view.

The keyboard shortcut to revert to actual size is Command-0 (Command-Zero).

Those keyboard shortcuts work for plain or rich text, HTML, WebArchive, PDF and image documents, whether in normal or Full Screen view.

You’re absolutely right! Thanks Bill! I’m embarrassed to say that I never even though of that. :confused: Chalk it up to dissertation stress.

Still, it would be kinda cool if the Preferences’ option really worked as stated. Now that I’m losing my mind, I’ve become hyper-enviro-sensitive: things like incense, music, and text layout have really started to affect my morale. I’d like to use a VT100 font with that soothing green-on-black and flashback to the Bankstreet Writer days. :bulb:

I’ll be waiting for PB9, I guess. Sometimes it’s the little things …