German default

When I type into my browser, the site comes up in German. How do I make it come up in English?

(Eigentlich so schlimm ist es nicht. Aber immerhin es ist schneller und einfacher für mich auf Englisch.)


Which browser do you use and what’s your system language?

I use Safari and the system language is English.

The website switch uses the default browser language to choose the correct version. I am using English as my system language, too, and our website correctly loads in English.

That was interesting. I looked in Preferences -> Advanced and the Default encoding was set to “Western (IOS Latin 1).” I changed it Western (Mac OS Roman), opened a new tab and went to and it came up in English for the first time.

So then, I closed the tab, went back to preferences and changed it back to “Western (IOS Latin 1)”, went back to the site and now it came up in English again.

I really don’t understand and I imagine this is not the same as what you’re talking about, that is the System language that I remember setting in setup.

But, whatever it is, when I go to this site now it comes up in English.