Getting URLs into DTTG - still bugs [solved, beside WebArchives]

I actually wonder whether you need to go further than that and reinstall the iPad, putting back DTTG at an early stage and then watching to see whether anything else you install disrupts the behaviour between Safari and DTTG. But as I said, I’m not sufficiently knowledgeable in the workings of iOS to judge how likely that actually is. I grew up with Windows (after OS/2, that is), where in the day such interactions were highly probable.

I simply cannot do that.

But if there is no other way to force this registration, I would of course reinstall DTTG again…

Have you restarted your iPad? I’ve read from top and I think you haven’t done… 99% of strange behavior in iOS (and macOS) is solved doing a Windows :sweat_smile: (Restart).

1 Like

We can reproduce the issue here and will investigate. Technically, DEVONthink To Go registers itself as “accept everything” so there must be more to it when it comes to web archives.

3 Likes

Many many thanks :hugs::hugs::hugs:

So I will wait before I try a new install.

A reboot, even that hard-reboot (press two buttons until the Apple appears) did not help!
I still can not share URLs or WebArchives at all on the Air 3.

Would this also fix the problem with drag and drop and the “Pasted Bookmark” name?

If I add an URL to Safari Favorites, it knows and offers the proper title of the webpage - it would be great when drag-and-drop bookmarks would have this name too… like when shared to DTTG (if that worked)

Unfortunately, after checking with our developer, we have tried for a while to get web archives from Safari. What ever we put into the property list that defines which file types the app can except, Safari only delivers the URL and never any web archive.

What does work is to share with the Files app and select DEVONthink To Go as a destination there.

Hi, regarding not seeing DDDG in the Share menu, just out of curiosity, try to force-restart your iPad. I’ve noticed that ever time I install an update I experience the same thing. If I force-restart my iPad the Share menu reappears. FWIW

Good luck

Many thanks.

I still seem to remember, that this worker earlier - with DTTG 2.x and some earlier version of iPadOS or iOS.

I may be able to test this on an older iPad

I did deleted some of the App that accept bookmarks / URLs, then made a hard reboot again and only then reinstalled those Apps.

After that, DTTG reappeared in the share sheet for “Automatic”.

That is a relieve :hugs::sweat_smile:

There could be some suspicion coming up that there might be factors involved out of our all control. Dark forces? Magic? 🪄

1 Like

As I already mentioned at the beginning: a quick search for this issue reveals multiple people complaining about app icons that seem to disappear at random in the share sheet since iOS 14 was introduced.

That obviously doesn’t conclusively mean DTTG is bugfree regarding that aspect, but I find it more likely that the culprit is some iOS 14 bug that underlies this behavior.

1 Like

I sometimes have exactly this feeling :smiley:

In earlier versions of the OS I never had similar problems, but at some point things went bad.

When checking the list of available Apps, I noticed that the whole list is strange - many Apps I would expect to show up are simply not listed at all.

But Apple concentrates on creating new Emoyees(?) instead.

That’s predictable behavior of any product that grows in complexity I’m afraid. The more lines of code or dependencies that arise, the higher the chance of some unexpected behavior.

It’s nothing else but the second law of thermodynamics. Or as one of my teacher taught me years ago: why don’t rooms tidy themselves? Because of entropy.

Or even dark magic?
:wink: