Getting URLs into DTTG - still bugs [solved, beside WebArchives]

Dear people from DevonTechnologies!

I think, we discussed this already.
But I still cannot work with DTTG.

If I try to share an URL from Safari to DTTG, it simply is not available as target!
This may be, because Apple felt the need to share URLs as “Rich Links”, which nobody needs or wants. But DTTG does not accept them.

When I change the “Send As” Option first and change “Automatic” to “PDF”, DTTG comes available as target.

When I change this to “WebArchive”, DTTG disappears again.

This is already… horrific and nearly removes any use for DTTG.
I can neither collect and classify / group URLs nor WebArchives, only PDFs.

But it get’s even worse:

When I run Safari side by side with DTTG, I can open a category / folder in DTTG and drag the URL over from Safari.


Any and all such URL gets the name “Pasted Bookmark”. We discussed this already.

Shall I finally uninstall DTTG?!?

Getting URLs into DTTG in a comfortable manner seems to be one of the most often used things done. It is one of main uses for it.

In theory.
As it still just does not work.
At all.

Can we somehow expect those things to be fixed?

A user who loved both DEVONthink and DTTG, but who continues to get frustrated endlessly.

I’m at latest DTTG 3 and iPadOS.

Could you try this:

  1. Open Safari on iOS
  2. Visit
  3. Press the ‘share’ button (blue square with arrow pointing out)
  4. Select the DTTG icon
  5. Press the blue ‘>’ to move forward
  6. Select PDF and press ‘Done’
  7. Open DTTG
  8. Open the most recently added PDF
  9. Review the meta-data by clicking the ‘i’ button in DTTG and check the URL

Do you experience a problem? If so, at what step number does it occur?

As I wrote above, this does not work.
DTTG is not available in the share menu.

It only shows up for the Safari option “PDF”, not when using “Automatic” or “WebArchive”.

And yes, I double-checked by using the Edit button in the share menu.

And in case, this was unclear, I meant step 4)

Some evidences:

Thats all.

For me the DTTG icon is available both for PDF (and Reader PDF) and automatic, but not for WebArchive.

Then it can even behave differently :open_mouth:

I realise you wrote you were using the latest iOS and DTTG; does that mean 14.6 and 3.7.2 respectively?



iPadOS 14.6

But my DTTG shows 3.1.1 (17082)

As I update my Apps several times daily, this seems to be the latest version.

My mistake, sorry - 3.1.1 is what I meant (3.7.2 is DT)

No problem :sweat_smile:

To be honest, I would be most happy, if drag and drop would work cleanly.

This is, because it is MUCH faster to get URLs from Safari into DTTG categories and allows to just use existing folders.

Sharing to DTTG is valuable, of course, but it is much faster and there better suited for some few URLs, esp. if you want to tag them.

But of course it would be best when both things could finally just WORK!

So, what is causing the behaviour to differ between our two devices. I’m using an iPad Pro 11” 2nd gen. Presumably either different models behaviour differently, or a piece of software you have installed is interfering with the behaviour of DTTG? I know too little about how software registers it’s capabilities to the OS to be able to usefully suggest whether or not that could be a cause of the problem…

I doubt whether this actually is a DTTG bug. I think it’s some kind of iOS issue.

If you search for this issue, you’ll find multiple people complaining about icons that have gone missing in iOS 14. I don’t experience a problem alike yours at all.

A similar problem cropped up on macOS; I wonder whether they are related? Do you use DT on macOS? If so, you could adapt the solution I posted in the linked thread to deal with any items called “Pasted Bookmark”. Not a solution maybe, but an automated workaround.

I recently removed DTTG from all my devices and reinstalled everthing, also I totally remade and split my databases from a remote location.

So, everything should be in the best condition.

Any way to “force” registering DTTG again with Safari / the Share sheet?

I have DTTG installed on 3 devices:

iPad Pro 12.9 2nd generation
iPad Air 3 (this is what I am currently using)
iPhone 6s

I am going to check all of them and report back!

Certainly worth doing; I’ve just checked my iPhone and see the same behaviour there as on my iPad - sharing with DTTG is available for “automatic” or “PDF” but not for “WebArchive”

My iPhone 6s behaves like your devices!

PDF and Automatic work!

But not WebArchive…

Presumably DTTG isn’t registered as an appropriate handler with iOS; @eboehnisch ?

And my iPad Pro 12.9 2nd generation also shows this behavior.

That would explain why all three devices cannot share WebArchives from Safari to DTTG.

I seem to remember that I used this earlier… maybe with DTTG 2.x?

And my iPad Air 3 has more serious problems… as it cannot handle the “Automatic” version.

Edit: I already fear that I need to reinstall DTTG again :sweat_smile: