"Glitchy" behavior when selecting an item


I hope I can describe this accurately.

With 2.5.1, if I select an item and then pull up the contextual menu, and then (for example) label it, when the contextual menu closes, the item gets dragged across the screen. I am not, absolutely not, dragging the items myself. I admit I’m using a laptop with trackpad, which could allow for accidental touches, but 1) this happens every single time I use the contextual menu to label items, 2) it didn’t happen until recently (at least starting with v2.5).

The automatic dragging appears to move towards where the mouse pointer is visibly resting. It can also be delayed for a few milliseconds–for a noticeable time.

I’ve had items move themselves into folders on their own this way, and then I have to go fish them out.

I haven’t tried to reproduce this with a mouse. I’m using trackpad with control button.

Mountain Lion 10.8.3.

I haven’t seen this one in DEVONthink, but it happens in Mail – messages seem to select themselves and move to another folder. Over here, it’s caused by one of the three-fingered trackpad gestures on my MacBook Air. WIth a three-fingered drag in DEVONthink, it is possible to hover over a document, without clicking, swipe across the screen and move the document anywhere that will receive it.

Do you use any third-party extensions/haxies like 1password, Default Folder X, SIMBL, Parallels etc.?

With my MBA’s trackpad, but not my mini’s Magic Mouse, I see a brief “animation effect” when using context menu commands to flag, label, etc. items (DtPO 2.5.1). I’ve never noticed items “move themselves” into different groups with any system/device usage.

@korm: I have three-finger drag turned off. (I turned it on just to see if it fixed the problem. It didn’t.)

@cgrunenberg: I have 1Password and Parallels installed on my computer. This problem started before I installed Parallels though. But they aren’t extensions…or at least not installed as extensions. (I don’t, for example, have the 1Password Safari extension, if that’s what you mean.)

@sjk: This is definitely more than an “animation effect,” unfortunately. It freezes up my computer for a sec while whatever was selected gets dragged across the screen.

The problem does not occur with a mouse. I tried it. But it happens with my trackpad, even with three-finger drag turned off.

I hope this is useful…

Thanks for the help

Note that I am seeing the behavior with a mouse too (just tested and verified - and my laptop is a 2009 non-touch trackpad).