Global in-box doesn't display


Again, my global In-box has disappeared. Yes, I tried the old hack or work-around to get it back, but it still disappears. What can I do to fix this?

One would think that this issue would’ve been addressed by now.

I’m using DT Pro 2.4.3.

I’m assuming that the left Sidebar of a database view window, which displays the Global Inbox as “Inbox” is visible, but the "inbox"database isn’t there. (If the left Sidebar isn’t visible, choose View > Show Sidebar.)

In that case, probably something has happened to damage the Global Inbox, such that DEVONthink cannot open it when launched. Other possibilities include a damaged and “stuck” cache, operating system instability, a damaged disk directory, preferences problems, etc. When something flaky happens, it’s possible that there are transitory errors in the computer’s memory that can be corrected simply by a Restart.

I’ve been working with DEVONthink databases for years and have never experienced a disappearing Global Inbox. But database damage can occur, although I’ve not had any problems for years.

Although I mentioned that I haven’t experienced any errors for a very long time, I still run a comprehensive backup strategy including Time Machine and DEVONthink Pro/Office database archives), as Bad Things such as a disk crash can and do happen. It’s a good idea to occasionally run Apple’s Disk Utility app to check for Preferences issues and to verify the disk. Every few weeks I run an OS X maintenance utility, such as C0cktail or OnyX, especially for cache cleaning, to help keep the operating system running cleanly and without errors.

If a problem recurs, it may be related to the software environment on the computer. It becomes prudent to occasionally run Tools > Verify & Repair manually, to check for errors in the database(s).

I mentioned the software environment. Back in the days of the Tiger operating system the number of problems caused by utilities that hacked OS X to change features or the appearance of the OS multiplied, causing havoc by introducing errors. (Unsanity’s haxies became legendary for such problems.) Since Tiger, Apple has introduced more stringent controls on third party apps that hack the OS, but there are still some that do. One way to check whether the software environment installed on a computer has made it unstable is to create a Guest User Account, and run one’s major applications under that account to see if problems go away.

I don’t know what your ‘old hack’ was, but I solved this problem by :

  1. closing DEVONthink

  2. going to ~/Library/Application Support/DEVONthink Pro 2/

  3. moving the Inbox.dtbase2 to the desktop

  4. restarting DEVONthink (the Global Inbox should appear in the sidebar)

  5. opening the Inbox.dtbase2 on the desktop as a ‘normal’ database and coping the content to the new Global Inbox

  6. deleting the Inbox.dtbase2 on the desktop

I hope that will help you.

That was the old hack. It’s been around since before 2004, when I first heard of it here in these fora.

OK. I tried it again. Yes, I got back the global inbox (just like last time), and now hold my breath until it disappears again.

BTW what does, opening the Inbox.dtbase2 on the desktop as a ‘normal’ database mean? When I double click on it, something momentarily flashes on the screen, then nothing; no access to it.

First off, thank you for your post. You put in a lot of time. Yes, your initial assumption is correct. However if you’ve been working with DT but haven’t experienced this problem, I’m sure you’re aware of it; it’s been around since before I got here in '04.

Yes, I’ve restarted, I do thorough maintenance (DiskWarrior, Onyx, disk permissions/repair, fsck -yf, etc.) I’ve been a Mac user since '93.

The suggestion to create a Guest User Account sounds reasonable. I’ll try that. Thanks.

I am sure, the database of your Gobal Inbox is corrupt, maybe this is the reason for not appearing in the sidebar as well as crashing when trying to open.

But you can get your documents back, when you open the package of the Inbox.database. The file-structure is a little bit irritating, but your documents are not lost - you find them in the folder “file.noindex”.

OK. Thanks.