Global inbox doesn't sync anymore

Using Bonjour to sync a Mac and an iPhone worked fine in the past, however I can’t get the global inbox to successfully sync anymore, I always get something like this:

The setup didn’t change. Other databases do sync. Already tried rebooting etc. but coudn’t find a way to fix it. Also tried the direct connection via cable. There seems to be no way.

So currenty I’ve got un-synced (and new) records on Mac and iPhone. No idea how to deal with this. Bonjour is the only sync method I ever used.

Verify the database on both machines? anything here work? Global Inbox not working anymore - #16 by Cassady

1 Like

Verified both, both ok.

My next step would be to move the records in the global inbox into another database one by one and see whether that database stops syncing at any point; what I’m wondering is whether there is some file attribute (a special character?) snarling things up. As a shortcut, you could - especially if there are lots of records - move all records to another database and create one new record in the global inbox to test whether that syncs. (Don’t forget records in trash).

My next step if that didn’t work would be to copy the inbox database file from on device to another (via Finder, e.g. using AirDrop or a USB stick), and to see whether they sync after that (and if not, probably I’d try the copy the other way round, so make a copy before overwriting).

If that all didn’t work I’d come back here to see if anybody who actually knows what they are talking about had posted.

[edit: I had missed that the second device is an iOS device, so some suggestions are not immediately applicable]


Thanks Blanc! I considered that before posting. However, I treat the “global inbox” as a normal database that’s always available (i.e. it contains everything I always need quick access to, e.g. apps’
help files etc. Tried different database setups, but it turned out that I needed to look something up that often that using the global inbox was (for me) the fastest way.). So there are 3 GB in my “inbox” - and unsynced records

Is there enough space available on both devices? Are you running firewall or antivirus software?




The setup didn’t change. No idea.

Have you tried turning things round, so making the iPhone the server and the Mac the client or vice versa?

In the iOS screenshot you posted, you are currently not connected to WLAN. Can you confirm that during the sync your phone remains connected to WLAN?

1 Like

No. Did you use this to resolve sync issues in the past? Should’t make a difference which one is the server, I think.

Took this while trying via cable. That’s what I don’t get: I can’t recall situations where Bonjour via cable failed before.

I’ve now checked file integrity again, it now reported 6 errors, so I rebuilt the database and checked integrity afterwards, all fine. But still the Bonjour connection gets lost, i.e. still can’t sync the global inbox.

I found one RSS feed item whose name starts with . . After deleting it sync works again. Thank you very much :smiley:

1 Like

Ahmm … sync works again - but the record I deleted was created after snyc didn’t work for some days (didn’t need it to work so didn’t pay attention).

So although it works I’ve still no idea why it works again :man_shrugging:

Ok, maybe I found why a (normally) completely reliable sync via Bonjour starts to fail.

On iPhone there’s one action (which I only use occasionally) that creates a Markdown record in a Dropbox folder (indexed in DEVONthink).

It seems Bonjour sync starts to fail when there’s a new record in this indexed group.

After creating a Smart Rule (that moves any new record from the folder into the database before syncing) sync seems to work reliably.

@cgrunenberg is this a known issue?

There’s no such known issue, right now I can’t even imagine how this might be possible. Maybe some kind of race condition? Please choose Help > Report Bug while pressing the Alt modifier key and send the result to cgrunenberg - at - - thanks! Maybe there’s something useful in the logs.

By the way, are you able to reproduce the issue by creating a Markdown file directly on the Mac in the same folder? Are local copies of all files in the Dropbox folder available?


  • If the record is indexed snyc via bonjour fails.
  • If it’s not indexed sync succeeds.

Sure, now and also had never problems accessing them in the past,

Sorry, I won’t share logs.

Are incoming connections only enabled on this computer and is this the only sync location?

Ohh, incoming connections were enabled on mac and iPhone, no idea how that happened. Bonjour is the only sync I use.

I’ll see how it works. Thanks!

I couldn’t reproduce this using only two Macs so far.