Global inbox missing?

I just noticed that my global inbox is missing. I have stuff there that I would like to access, what do I do?

This happened to me too, a few days ago. I thrashed around for a while, and it came back. Verify and repair found no errors. I quit and restarted a few times. I really don’t know what brought it back.

I have also done a few verify and repair without errors showing up. Devon keeps telling me that some databases are in use. I just say OK, but it would be nice to be able to access my documents in my inbox.

Ok, I fixed it, here is how (this is just how I did, DEVON might have other opinions?):

  1. Start DEVONThink.
  2. Turn of the Sorter.
  3. Quit DEVONThink.
  4. Copy ~/Library/Application Support/DEVONthink Pro 2/Inbox.dtBase2 to someplace and rename it. (this is the inbox)
  5. Open the renamed Inbox in DEVONThink and copy you stuff to another database.
  6. Quit DEVONThink
  7. Delete ~/Library/Application Support/DEVONthink Pro 2/Inbox.dtBase2
  8. Restart DEVONThink
  9. Turn on the Sorter if you want.

You now have a new inbox. If you want, you can move back the inbox you copied previously.

1 Like

This will work, although sometimes just quitting DT Pro/Office2 and restarting the computer will do the job. This is one of those glitches that a few have encountered and that I’ve never seen.

But a cautionary note to those unfamiliar with Mac conventions, who might get confused and create problems for themselves:

In eatmytag’s step 4), don’t copy your entire Library folder to another location. Just locate and copy the file named Inbox.dtBase2. To copy a file, hold down the Option key while dragging it to another location.

As eatmytag’s path indicates, open a window in the Finder and click on the ‘House’ icon, which is your user directory – then click on Library, Application Support, DT Pro Office 2 in succession to reveal the file named Inbox.dtBase2.

And in step 7), locate and delete ONLY the file named Inbox.dtBase2.

I would recommend that these procedures should be done after one has Quit DT Pro/Office 2. It’s not a good idea to copy or delete files while they are open.

Thanks – I think I may see a problem. In my initial purchase, I tried DT 2 and DTpro 2 before purchasing DT PRO Office.

There is no Application support for DT Pro Office Global inbox shows up in DT Sorter.

I also changed the name of my database in the finder. How do I fix this mess I created.

Thanks Songdog OSX 10.7.1 DTPO.

I am having a similar problem. When I open DTPro Office 2.3 I only see my default database. I can open the other databases and then I see them. The Global Inbox then appears and it has -2 items. Any suggestions on how I can fix this?


This is driving me silly, it happens so regularly. Four years of this bug being reported and still no fix. Is one on the way?

I agree. This happens for me about once per week. I know the fix. Deleting the inbox.dtBase2 in Applications Support/Devonthink Pro 2. (By the way, there was also a Devonthink Pro Office 2 there as well, which contains no files, so I deleted it.) I am using DTPO. I understand that once the Global Inbox is deleted, and rerun, I can then return the old Inbox.dtBase2 to it’s original place, although I think I will avoid the Global Inbox for now, and risk losing files added there. Maybe I should go back to using the Sorter.
I should mention that my DTPO setup files are in my Mac/Documents, but the files are in databases in my WD MyCloud 2TB NAS drive.

Sounds like you’ve “customized” your configuration … ever considered that might be why the application does not work correctly? Consider opening a ticket with Support to get real help? The forum is not good for fixing configuration problems.