Global Inbox not working

I’m having a huge problem with the global Inbox to the point that Devon Think has become useless to me. Just to say I’m running OS X 10.6.6 and DevonThink Pro Office Version 2.0.6.

If I try to add something to my Inbox either via the shortcut Apple+( or via the Safari Extension I get the visual feedback from the dock Icon that something has been added, but when I go and check there is nothing new in my Inbox!

The worst thing about this is the dock icon showing a red star with numbers in it made me think my items were saved and now I’ve found that I’ve lost everything I thought I’d been saving for the last week!

I’ve search for help and found devon’s own article on this: … at=24#a104

I followed those instructions but when I restarted my Devonthink I had the same Inbox with the same three items that where there before I moved the Inbox and Inbox.dtBase2 to my desktop. I’ve now tried organising those three items but no change.

So right now Devonthink is badly broken for me.

What 3 items are in the new Global Inbox? There should be nothing in a new Global Inbox other than an empty Tags group.

There where three URLs that I had managed to get into the global inbox before it stopped working. I tried clearing them out and deleted the inbox and Inbox.dtBase2 again but it didn’t help.

This is very weird, I just tried “Show Package Contents” on Inbox.dtBase2 and I could see there where 4 items in the “webloc” folder but my Global Inbox was empty. I just used Apple+( to add another URL and it appears immediately in the Inbox.dtBase2 webloc folder, but it’s still not being displayed in my Inbox.

The bonus here is that if I had tried looking in Inbox.dtBase2 earlier on I would have probably found all the things I thought I had lost, but I deleted it and Emptied my Trash to make sure. DOH!

Hang on Time Machine to the rescue, managed to get back everything :wink:
Now when I do get the Inbox working again I put all this stuff back in.

Here is some more weird stuff.

If I drag a URL from Safari to the Inbox area then it shows up, but it does not appear inside inbox.dtBase2/Files.noindex

If I use a keyboard shortcut then the URL doesn’t show up in the Inbox but it does get added to inbox.dtBase2/Files.noindex/webloc

Now if I delete the Inbox folder and the Inbox.dtBase2 package and then restart Devonthink I still see all the items I added into the Inbox by using the drag n drop method.

OK, I’m an idiot, I’ll leave this thread here even though it makes me look stupid as it may help someone else.

What I thought was my global Inbox was actually the inbox for my current database, I wasn’t looking at the global inbox as I had the sidebar turned off.

So just to repeat, nothing wrong with devonthink just me not using it correctly.