Have devon identify as … browser?


Still happily using Devonthink Pro 2.11.2, some web pages don’t open in that app (or at least not in mine). Maybe because, as Devonthink Help explains, some servers don’t allow their web pages to open in browsers they don’t recognize. This appears to be the case e.g. with https://www.pinterest.de/pin/258886678552331193/ (or does this page open in your Devonthink, and accordingly the problem lies elsewhere?).

Now, if it in fact is the case that pinterest’s server refuses to open pages on unrecognized servers, would there be a way to have Devonthink’s browser identify as some known browser? (Safari offers such an option in the Develop section (choosing the User Agent), so in principle that seems to be possible.)


DEVONthink 2 is out of development and as far as I know it’s also not possible to identify as browser.

Thanks Pete. I know it’s out of development (and it speaks in its favour that it still works smoothly), but I thought maybe that’s a feature I haven’t found yet.

Does this url open in your version of D.?

Yes, it works in DEVONthink 3.

Ok, interesting. Thanks for trying and letting me know, much appreciated. I’ll upgrade at some point without a doubt—however I’d still be curious to hear if anyone can open that link in Dt2, since that would point to some particular problem in my setup that may equally occur when upgrading.

I don’t know if it is relevant to this case, but there is a utility called Choosy that will let you specify which browser to use in circumstances of your choosing. So you can specify that a certain site will open in Chrome instead of Safari, for example. No idea if or how it might work with DT.

EDIT: OpenIn does much the same.

Hello, thanks, not bad. I would still like to have urls, weblocs etc. open within Dtp, but this choosy may come in handy on occasion.

I know that you can tell Choosy that DT3 is a browser, so theoretically it should be possible to tell it to open Pinterest links in DT3, but I don’t know if the same could be done for DT2. There is a free trial of Choosy (44 days, I believe), so you could give it a go.

Oh, I see, yes, good idea. I tried that, in my case, it doesn’t work—but I tried it in Dtp3, too (in an up to date version), and it doesn’t work there either, which finally had me come up with the rather obvious idea of trying it on another computer, one that runs an up to date OS as opposed to El Capitan, the system I am experiencing the above described problem under. And indeed it works fine both in Dtp2 and 3 when running under Monterey on a machine that isn’t considerably older than a decade.

1 Like