Help to get global inbox functioning again please?

Hi Everyone, I need a little help to get my global inbox going again. Here’s some information that may have lead to it not functioning any more.

  • I’m on a mid 2015 macbook pro
  • In at has been a 2 TB OWC ssd
  • this ssd has been failing on me, but I managed to copy most of it (maybe partly damaged) to an external harddrive. This harddrive is the single drive built into a 4-drive external housing (Addonics). The Addonics housing is connected using esata cabling with a CalDigit TS2 Thunderbolt docking station.
    This may sound complex, but all is working.

Due to the failing OWC 2TB ssd, I had to revert to the original 250 GB ssd.
Of course this brought big trouble but I managed to downsize my disks content to fit the much smaller 250 GB drive.

One of the side effects (that I did not expect or foresee) is that macOS (I’m on Mojave) also seems to take into account the /Applications/folder that is on the mounted external drive (when and if it is connected).
This made it such, that on the “older” copy of my macOS system DTPO v3 is installed and on the 250 GB DTPO v2 is installed. (Yes you guessed it right I still use a mix of v2 and v3 for various reasons)

Not being aware of this initially I was stumped at why at one time I would have v3 and at another time I would have v2. This was off course when the external disk was mounted or not.

Now recently my global INBOX, the one that is also visible in the Finder stopped auto-importing. So anything I save to the INBOX just stays there and is visible in the Finder but does not get imported into DTPO.

I can see that the respective INBOXes live in /users/erwin/Library/Application Support/DEVONthink 3/ and ˜/***/DEVONthink Pro 2/

What do I need to do to reenable auto-importing from the INBOX?
I’m still waiting (over 6 weeks now) for the warranty replacement SSD from OWC, so I guess this situation is not over within the next couple of days.

How can I change the global INBOX from either v2 to v3 and vice versa?

For what it’s worth: it seems a “read only” icon has established itself, but I don’t know why or how to make it “writable” again. Maybe that is the cause?

Thanks for understanding and helping out!

For a moment thought it was working again - but it is not…
I tried the below article but it did not solve my issue.

In the mean time I found this in wayback machine (Thanks Beck for running into the same issue :wink: )
I take the liberty to copy the small article in here as it may help others running into a similar situation:

Tuesday Tip: Save directly to DEVONthink

Starting with public beta 5, DEVONthink offers the possibility to save any file from any application directly to the global inbox. No more saving to the Desktop and importing later.

First make sure that this function is enabled. Choose Help > Install Add-Ons, check ‘Global Inbox in Save Dialogs’ and click ‘Install’. This inserts a shortcut to the global inbox into the Finder’s sidebar. To save a document to DEVONthink now, look for the ‘Inbox’ item in the sidebar of the save dialog and select it as the location of choice. This even works when DEVONthink is not open, the document will be imported when you open the application the next time.


Could you elaborate on what these reasons are?

Call it matter of preference.
Mainly because I still prefer the 3 pane layout of v2, but also because my spouse and myself use shared DB’s and v2 supports this whereas v3 needs a paid upgrade to allow this.

V2 and V3 use the same format of syncstore so I learned.
There are also differences in the annotation templates so I found, and contrary to what is explained elsewhere on the forum, annotations made in v2 right-clicking an item > New from template > Annotation is not equivalent to the annotation you make in v3.
But i’m not 100% clear on that one yet.

Ok, seem to have found a way to a solution:
Will report back if I run into trouble again… and, oh yeah, the “read only icon has disappeared”… :wink:

From Jim here:


Nov '19

Control-click and remove it from the Finder’s sidebar then install it again from DEVONthink 3 > Install Add-Ons … and do not rename the sidebar alias (in case you did or wanted to) .