Help with RSS, archives and workflow... please...

Rebooting can indeed fix weird issues of applications, e.g. after an uncaught exception, a frozen background task or caching issues.

Here’s an oddity for you…

I ran the search manually and it found 215+ new results. However, it did not update the rss file. It appears that the rss file was last updated when the search ran due to its programed schedule earlier this morning.

Any thoughts on why that might be?

Just for giggles, I manually ran another unrelated search and it returned results and updated its rss file.



Any messages in the Console? Or could you send both the used script and the search set to our support address? Maybe we’re able to reproduce the issue.

It look alike it is returning the following message in the Console app:

12/19/13 10:22:12.444 AM devongetd[1803]: SecOSStatusWith error:[-34018] The operation couldn’t be completed. (OSStatus error -34018 - Remote error : The operation couldn‚Äôt be completed. (OSStatus error -34018 - client has neither application-identifier nor keychain-access-groups entitlements))

Would that make sense?


devongetd is a background task used by DEVONagent/think but not related to searching or executing scripts. Any chance that you could send me the search set and the script?

Sure. What address should I send it to?

cgrunenberg - at -

New wrinkle here… All was working great until I upgraded to El Capitan. Now, I can seem to get the OS to open up web sharing from the individual users folders. localhost/ works great. http"//localhost/~username/ gives me a notice that I don’t have permission to access that folder. All this means DT is doing its part and updating the rss files in the “Sites/rss/” folder, but I can’t get to them.

Any thoughts?


I’m still having issues with accessing the RSS files created by DA, unfortunately…

Trying to go to localhost/ gives me the “It Works!” page.

New thoughts?


Which version of macOS do you use? The latest releases don’t support web sharing anymore, at least not easily. But you could use file:/// URLs instead (depends of the app of course).

I’m on 10.12.3.

How did you actually activate the web sharing? And did you copy the RSS files to the server’s directory (in the past ~/Sites)?

To activate web sharing I followed the instructions from earlier in this post. I haven’t copied anything into the Sites folder. DA has been the only program to write to the Sites/rss/ folder. Does that help?

Did you try the URL What’s in the ~/Sites/RSS folder currently?

I did try that URL and got back a message that it isn’t found on this server. Currently there are only 3 files in the /rss/ folder - all .rss files and all created by DA.

Could you please post the exactly used URL plus the exact names of the files in the rss folder? THanks!

I’ve tried: and and
All have the same result - a 404 not found message

In the directory are:


The second one should actually work, assuming that the webserver uses indeed the ~/Sites folder. However, the next maintenance release of DEVONthink will also support file URLs, then you could simply use file:///Users/bradrodgers/rss/sustfarm.rss without having to activate the server.