How can I silence or prevent the "unknown format" warnings?

Hi all,

I am bringing more and more of “textual data” into Devonthink, the ease of rapid search across a scope I define is priceless.

One corpus is a bunch of org-mode files, ending with an .org suffix, and I keep seeing the warning notification about them being in an “unknown format”.

This isn’t affecting me in any way, it’s a small issue, but still, I’d like to avoid these warnings if possible – so is there a way to let Devonthink know “this format is okay”? Or is this something that needs to be configured at the MacOS level?
Much thanks,

P.S. I did see a similar post, from seven years ago that was unanswered, but I’m guessing the way things work might have changed since then, so re-posting.

org-mode files are text based, so you could add it as an additional plain text extension.

See the Help > Documentation > Appendix > Hidden Preferences for instructions on how to add the extension.

Note: After the change and relaunch of DEVONthink, you should make sure your local bakcups are current (as a general admonition and a safety measure) then do a File > Rebuild Database on the database(s) with the .org files in it.

1 Like

Thanks, I did try this, but:

$ defaults read com.devon-technologies.think3 AdditionalPlainTextExtensions
2020-08-14 17:24:23.916 defaults[22911:48931006]
The domain/default pair of (com.devon-technologies.think3, AdditionalPlainTextExtensions) does not exist

(I can confirm that I do see the entire set of preferences when I run defaults read com.devon-technologies.think3 though)

Sorry, I should have read ahead. I thought the missing setting was an error, but looks like it is normal.

It does work!

$ defaults write com.devon-technologies.think3 AdditionalPlainTextExtensions -string .org

$ defaults read com.devon-technologies.think3 AdditionalPlainTextExtensions


You’re welcome :slight_smile: